moving the cursor in a textbox with ctrl+arrow treats newline like white space

RESOLVED INCOMPLETE

Status

()

--
minor
RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: adand, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

using ctrl+arrow to move through text doesn't act as expected.

Reproducible: Always

Steps to Reproduce:
1. type a line into a text box and follow with several newlines
2. from the top left, use ctrl+right arrow to jump from word to word
Actual Results:  
it jumps from the start of the last word to the bottom of the box.

Expected Results:  
it should jump to the end of the line, then to each line after.
I cant reproduce, it works for me
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

9 years ago
try this:
1. in the comment box below enter "hello world" and then push enter a few times
2. put the cursor in the top left corner
3. push ctrl+rightarrow, this should put the cursor at the beginning of "world"
4. push ctrl+rightarrow, this should put the the cursor at the end of "world"

but it doesn't.  it drops the cursor to the bottom of the box, after all the newlines.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

9 years ago
Duplicate of Core bug 327467?
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.