Custom Settings for History: exceptions not saved regarding blocking specific cookies.

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Real Name, Unassigned)

Tracking

3.5 Branch
Other
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

If I want to block (or allow) cookies as a exception to my settings, those exceptions are not saved (they are deleted) when Firefox closes. Previously in earlier FF versions the exceptions were always saved, even after FF closed the settings were saved and applied to the new browsing session. 

TOOLS>
OPTIONS>
USE CUSTOM SETTINGS>
COOKIES>
EXCEPTIONS>
BLOCK> "www.website-example.com"

Reproducible: Always

Steps to Reproduce:
1. Use Custom Settings for History.
2. Go to cookies, exceptions, and then block a specific site from storing cookies on your computer.
3. Close FF then check to see if the site continues to be blocked. You should see the list of exceptions has NO sites listed because the exceptions have not been saved.


Expected Results:  
The blocked site/s should always remain blocked after I've entered then as a blocked exception, therefore they should not be allowed to give me cookies for all future sessions even after FF closes and reopens.

The "accept cookies from sites" box is ticked and the "third party cookies" is NOT ticked.
Do you clear on close? What is the setting for "Site Preferences" in the "Settings for Clearing History" window?
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

9 years ago
Problem resolved thanks. Yes "site preferences" was set to clear.

The problem is that recently FF started crashing and I had to completely re-install it thus all my settings changed... thankfully it is fixed now (not sure how it got fixed: I did lots of other things in addition to re-installing)... Consequently I have become slightly distrustful of FF thus I am inclined now to see a problem where there isn't one.

Your help is appreciated.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.