Tabs loaded from previous sessions are still being restored despite explicitly closing them before I close the browser

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Lexie, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1)
Build Identifier: 3.5.3

Tabs I opened 3 days ago are still being re-loaded even time I strart a new session with Firefox 3.5.3.  This happens even when I explicitly close them before closing Firefox

Reproducible: Always

Steps to Reproduce:
1. Close all tabs individually
2. Close Firefox
3. Re-start Firefox

Explicitly closed tabs re-load.
Actual Results:  
explicitly closed tabs re-load upon re-starting.

Expected Results:  
Not restore the tabs explicitly closed before shutting Firefox down

This started since the upgrade to 3.5.3
(Reporter)

Updated

9 years ago
Summary: Tabs loaded from previous sessions (days ago) arre still being restored despite explicitly closing them before I close the browser → Tabs loaded from previous sessions are still being restored despite explicitly closing them before I close the browser
Version: unspecified → 3.5 Branch
(Reporter)

Comment 1

9 years ago
Please note the User/Agent is listed as Mozilla 4.0 but iss showing as Mozilla 5.0 in my version screen
Maybe a corrupt sessionstore.js file? In your profile folder please delete the sessionstore.js file and any copies, such as sessionstore-1.js, sessionstore-2.js. 
http://support.mozilla.com/en-US/kb/Profiles#How_to_find_your_profile
Please don't delete the sessionstore.js file! Just move it out of this folder. If there is a problem in this file we would need it to identify what's going on. Thanks.
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore
(Reporter)

Comment 4

9 years ago
Too late - Before Henrik got the chance to submit his comment I deleted the sessionstore and as bizarre as it may seem, the same 8 tabs keep opening. But now an additional ansillary window is spawning as well - don't have a clue where that came from.

After I read Henrik's comment I restored the sessionstore to its original location, but none of this has changed the behavior.  How could those tabs have been restored w/o a sessionstore file?

Lexie
Well, the file should be in your recycler if you don't do shift+delete, at least if the session restore people would need it.
Can you retest in safe-mode? http://support.mozilla.com/en-US/kb/Safe+Mode
or with a new profile: http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
(Reporter)

Comment 6

9 years ago
As I mentioned in my last post, i restored the session file without issue.

An interesting thing to note is that there are identical Mozilla folders in both the Application Data and Local Settings.  Might there be some conflict in session restoration if the two sessionstore files are in conflict, or is this as it should be?
If you look in Tools > Options > General, what is your homepage?
(Reporter)

Comment 8

9 years ago
Wow - looks like that was the problem.  The home page had somehow changed and concatenated 7 other sites along with my original homepage.  Very strange, but I think that was the problem.

The cause of that 7-url homepage however, remains to be discovered.

Thanks for your help.

L
(Reporter)

Comment 9

9 years ago
OK - restarted Firefox & indeed that last suggestion did the trick.  I'm marking this bug closed.

Thanks Ria.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Component: Session Restore → General
QA Contact: session.restore → general
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.