Clicking a partially off-screen link shouldn't scroll the page (again)

RESOLVED FIXED in mozilla1.9.3a1

Status

()

Core
Event Handling
P2
normal
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Assigned: masayuki)

Tracking

({regression})

Trunk
mozilla1.9.3a1
regression
Points:
---
Bug Flags:
blocking1.9.2 +

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090920 Firefox/3.7a1pre

This was fixed once before in bug 105894, but it's broken again.
(Reporter)

Updated

9 years ago
Keywords: regression
Created attachment 401796 [details] [diff] [review]
Patch v1.0

checking on the tryserver.
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
This should be a regression of the focus refactoring, we should fix this on 1.9.2 branch too.
Blocks: 178324
Flags: blocking1.9.2?
OS: Mac OS X → All
Hardware: x86 → All
Attachment #401796 - Flags: review?(enndeakin)

Comment 3

9 years ago
Comment on attachment 401796 [details] [diff] [review]
Patch v1.0

>+<window title="Focus Scroll Tests"
>+  onload="setTimeout(runTest, 0);"

You should use SimpleTest.waitForFocus since retrieving fm.focusedElement will rely on the window being focused.
Attachment #401796 - Flags: review?(enndeakin) → review+
Created attachment 401863 [details] [diff] [review]
Patch v1.1

thanks
Attachment #401796 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/6ae554d40a78
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Comment on attachment 401863 [details] [diff] [review]
Patch v1.1

We should fix this regression on 1.9.2 branch too. The risk is low. This patch only suppresses the scrolling at clicking a link.
Attachment #401863 - Flags: approval1.9.2?
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P2
You need to log in before you can comment on or make changes to this bug.