Last Comment Bug 517805 - Move printDialog to calendar/base/content
: Move printDialog to calendar/base/content
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Printing (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: 1.0b1
Assigned To: Martin Schröder [:mschroeder]
:
:
Mentors:
: 520389 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-20 16:17 PDT by Martin Schröder [:mschroeder]
Modified: 2010-02-04 11:05 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch v1 (25.91 KB, patch)
2009-09-20 16:17 PDT, Martin Schröder [:mschroeder]
philipp: review+
Details | Diff | Splinter Review

Description Martin Schröder [:mschroeder] 2009-09-20 16:17:33 PDT
Created attachment 401766 [details] [diff] [review]
Patch v1

Changes in this patch:

* Cleanup of printDialog.xul/js: braces, space, indentation, use 'let'

* Remove unused vars gPrintSettings and contractids (printDialog.js)

* Replace usage of string bundle with calGetString(...)

* Remove unused stylesheets, overlay and CSS class (printDialog.xul)

* Move printDialog.xul/js to calendar-print-dialog.xul/js in calendar/base/content/dialogs/ and change jar.mn & calUtils.js accordingly.
Comment 1 Philipp Kewisch [:Fallen] 2009-10-02 11:07:47 PDT
Comment on attachment 401766 [details] [diff] [review]
Patch v1

>+    let catenum = catman.enumerateCategory("cal-print-formatters");
> 
>     // Walk the list, adding items to the layout menupopup
>+    let layoutList = document.getElementById("layout-field");
>     while (catenum.hasMoreElements()) {
>+        let entry = catenum.getNext();
You may want to use iteratorUtils here, then you can just do for each (fixIterator(catman.enumerateCategory("cal-print-formatters")) {} or similar. Not sure if we've included this into Sunbird yet though.


Anyway, r=philipp
Comment 2 Martin Schröder [:mschroeder] 2009-10-04 01:19:06 PDT
*** Bug 520389 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.