Mail filter manual "run now" does not appear to work

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: baffoni, Unassigned)

Tracking

Trunk
Thunderbird 3.0rc1
x86
Windows XP
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090920 Shredder/3.0pre

Automatic filters seem to be working, but a simple filter based on email address will not run, and no entry is put into the filter log.

I don't know if it is relevant:
1) My gloda indexing (can't be offline, that is disabled) won't stop because I have hundreds of thousands of emails, so if indexing is blocking manual filters, this would make sense.  Stop button doesn't appear to help.

2) In "run selected filter on", no folder is visible/selecteable, only the account names are visible, selecting an account only creates a very small (maybe 8px x 8px, probably smaller) box instead of the sub folders.

3) This issue affects both local and IMAP folders.

So in prior versions, the filter worked perfectly (move emails ending in "@sans.org" to my sans newsletter folder).

1) select unchecked (not automatically applied) filter.  Ensure filter is enabled for manual run.
2) Click on "run now".

Expected behavior
3) Filter acts on email

Actual Behavior
4) Button depresses and rebounds, but no action is apparent.

Moving/deleting emails manually works fine.
Flags: blocking-thunderbird3?
Confirming on: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090915 Lightning/1.0pre Thunderbird/3.0b4

Error console exception:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFilterService.applyFiltersToFolders]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/FilterListDialog.js :: runSelectedFilters :: line 350"  data: no]
Flags: in-litmus?
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0rc1

Updated

9 years ago
Whiteboard: [no l10n impact]

Updated

9 years ago
Assignee: nobody → kent
Status: NEW → ASSIGNED

Comment 2

9 years ago
I'm not able to reproduce this - could I have some more details in the STR?
Duplicate of this bug: 518793
(Reporter)

Comment 4

9 years ago
This seems to be working in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090928 Shredder/3.0pre
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 5

9 years ago
It is not working for TB 3.0b4. It worked for 3.0b3. So needs to be reopened.

Comment 6

9 years ago
Jon, what this bug really needs is a clear description of steps to reproduce. I would be happy to fix it if I could reproduce it. If you could tell precisely what you are doing to reproduce it, including such details as the filter search term, the filter action, the folder being selected, and the type of account being filtered, then perhaps we could make some progress.

Comment 7

9 years ago
It has presented itself when I have opened a filter for editing, add a test to the list, commit the change, then try to manually run the filter to act on messages in the Inbox that I want it to act on (generally moving to a folder). It operates correctly on any new messages that come in, but not on ones already there, which I have to manually move.

It seems to make no difference which filter or the tests involved. They include tests on From, To, Subject, and Reply-To. The actions are all moves to a folder.

I can send you screenshots or a video if that would help.

Comment 8

9 years ago
Can you please test with the simpler filter action "Add Star" and tell me if the problem also appears for that action?

Also, for the move, what is the source folder (IMAP or Local) and what is the destination folder (Imap or local, same server or different server).

Comment 9

9 years ago
I created a new filter that tested whether the From field contained a certain domain name, and had it "Add star". After closing the edit window, I tried to "Run filter" from the still-open Message Filters window. It didn't work. Then I closed the "Message Filters" window and clicked on the menu Tools | Run Message Filters on Folder. That worked. It is the button in the Message Filters window that is not working after an edit or creation of a filter. 

All folders are local. This is a POP account.

Comment 10

9 years ago
I still cannot reproduce this, whenever I try this is works just fine.

Since this is local/pop, there is a distinction between the "Local Folders" account, and the account for the POP3 server. When you get to the filter list editor screen (with the title "Message Filters" in English), are you able to select more than one account in the "filters for" dropdown? If so, are you sure that you have the correct one selected?

Comment 11

9 years ago
I don't use Local Folders for anything but archiving. Each of eight POP accounts has its own Inbox, and the problem appears for each of them. Of course, I am running on Fedora 11 Linux but that shouldn't make a difference.
Duplicate of this bug: 525274

Updated

9 years ago
Assignee: kent → nobody
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.