unknownContentType.xul download dialog has type of file selected

RESOLVED FIXED in mozilla1.9.3a1

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: tnikkel, Assigned: enndeakin)

Tracking

({polish, regression, verified1.9.2})

Trunk
mozilla1.9.3a1
x86
Windows 2000
polish, regression, verified1.9.2
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.2 +
in-testsuite +

Firefox Tracking Flags

(status1.9.2 .2-fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
The unknownContentType.xul download dialog has the type of file selected (ie 'Binary file'). This happens for example when clicking on the first putty.exe download link in the URL. Bug 178324 caused the file type to have a visible cursor. Bug 508477 caused the whole field to be selected.
(Assignee)

Updated

9 years ago
Duplicate of this bug: 520449
Neil, caused by the focus rewrite?
Flags: wanted1.9.2+
Keywords: polish
(Assignee)

Comment 3

9 years ago
This bug is caused because there is a 

<textbox id="type" class="plain" readonly="true" flex="1"/>

at the top of the dialog and the code which sets initial focus finds it first. The solution is to do something like bug 513186 but handle textboxes as well (tricker as textbox.inputField is actually focused).

Or, we could just take the part of the second patch in that bug that fixes this as well.
(Assignee)

Comment 4

9 years ago
Created attachment 406055 [details] [diff] [review]
set noinitialfocus on the textbox and inherit it
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #406055 - Flags: review?(neil)

Updated

9 years ago
Attachment #406055 - Flags: review?(neil) → review+
(Assignee)

Comment 5

9 years ago
http://hg.mozilla.org/mozilla-central/rev/d6a03e3e6e6f
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Duplicate of this bug: 534766
Comment on attachment 406055 [details] [diff] [review]
set noinitialfocus on the textbox and inherit it

a192=beltzner, Neil, could you check this in?
Attachment #406055 - Flags: approval1.9.2+
1.9.2 approval for this expires at the end of the day (15 Dec) due to code freeze plans -- please land as soon as possible; if it bounces, it bounces hard.
Comment on attachment 406055 [details] [diff] [review]
set noinitialfocus on the textbox and inherit it

I guess this missed the cut-off. Kind of disappointing.
Attachment #406055 - Flags: approval1.9.2+ → approval1.9.2.1?
With Neil away until the 17th, can we get someone else to land this in the 1.9.2 branch for final?
It would need approval first.
Is there a separate fix needed for Mac?  This still happens with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a2pre) Gecko/20100223 Minefield/3.7a2pre.
Comment on attachment 406055 [details] [diff] [review]
set noinitialfocus on the textbox and inherit it

a1922=beltzner

Stephend - do you mean it's not fixed on OSX on 3.6 or trunk?
Attachment #406055 - Flags: approval1.9.2.2? → approval1.9.2.2+
(In reply to comment #13)
> (From update of attachment 406055 [details] [diff] [review])
> a1922=beltzner
> 
> Stephend - do you mean it's not fixed on OSX on 3.6 or trunk?

Both.
As per comment 12.

Neil, I'll leave it to you if you want to open a different bug for OSX or if you want to just make it part of this one.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The patch wasn't platform-specific, so if this is still a problem on OS X (I can't reproduce), it should be filed as a new bug.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(In reply to comment #16)
> The patch wasn't platform-specific, so if this is still a problem on OS X (I
> can't reproduce), it should be filed as a new bug.

I just reopened bug 520449, which was duped to this.
(Assignee)

Comment 18

9 years ago
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/110a1591e7d1
status1.9.2: --- → .2-fixed
Verified fixed on 1.9.2 with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)
Keywords: verified1.9.2
Target Milestone: --- → mozilla1.9.3a1
You need to log in before you can comment on or make changes to this bug.