Hard to place insertion point where there isn't text

VERIFIED DUPLICATE of bug 51747

Status

()

P3
normal
VERIFIED DUPLICATE of bug 51747
18 years ago
14 years ago

People

(Reporter: mikepinkerton, Assigned: mjudge)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
- edit a bug (http://bugzilla.mozilla.org/show_bug.cgi?id=1000)
- in the comment area, type

1
2
3
4

- click somewhere to the right of "2", say 2 inches away, in open space

Expected results:
- cursor is "i-bar"
- insertion point flases after "2"
- typing puts text after "2"

Actual results:
- cursor is a pointer, indicating you're not in a text area
- insertion point doesn't move after the click, so you don't know you it did
anything
- luckily, typing does put text after "2", but you'd never know it from the
visual feedback
(Reporter)

Comment 1

18 years ago
not dogfood, but makes using text fields very difficult. They just feel like
they don't work at all.
Keywords: nsbeta3

Comment 2

18 years ago
Dup of 51747, which is now fixed. Repull nsCaret.cpp/h and try again


*** This bug has been marked as a duplicate of 51747 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
This is a dup of bug 51747:Caret doesn't render at the end of line.
Status: RESOLVED → VERIFIED

Comment 4

14 years ago
fixing null OS field on old bugs
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.