Closed Bug 517916 Opened 12 years ago Closed 12 years ago

Crash [@ nsIFrame::HasView] occurs when clicking in the password field.

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: streetwolf52, Assigned: enndeakin)

References

()

Details

(Keywords: crash, regression)

Crash Data

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20090921 Minefield/3.7a1pre  Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20090921 Minefield/3.7a1pre

Clicking in the password field with or without a password causes a crash.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.pchgames.com/
2. Click in the password field at the top.
3. Crash!
Actual Results:  
Crash.

Expected Results:  
Should inform you that an invalid or no password was entered.  If a valid userid and password were entered you should be logged in successfully.

I am reporting this on behalf of someone else.  I am not a member of this site, but the fact that I can cause a crash seems to indicate it doesn't matter.
Version: unspecified → Trunk
You could please provide the crash IDs from about:crashes?
Crash,
http://crash-stats.mozilla.com/report/index/8df283cb-84e9-4e8e-bed8-bb9a82090921
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090921 Minefield/3.7a1pre ID:20090921050209
Confirming the crash, but I can only get it to crash on the main page of site listed in the URL above.  Navigating to another page then clicking on the password box does not result in crash. 

Today's nightly:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20090921 Minefield/3.7a1pre Firefox/3.7 (.NET CLR 3.5.30729) ID:20090921050209

cset: http://hg.mozilla.org/mozilla-central/rev/7799cfb99362

Crash ID:
http://crash-stats.mozilla.com/report/index/52db02c3-92c2-4301-9c21-558162090921?p=1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Crashes on Mac as well-> http://crash-stats.mozilla.com/report/pending/937e4371-46a1-4990-86f4-0608a2090921, changing OS and platform.
OS: Windows 7 → All
Hardware: x86_64 → All
From: http://crash-stats.mozilla.com/report/index/bd621860-0b07-478e-827d-af1b42090921?p=1
0  	xul.dll  	nsIFrame::HasView  	 layout/generic/nsIFrame.h:1562
1 	xul.dll 	nsIFrame::GetClosestView 	layout/generic/nsFrame.cpp:5419
2 	xul.dll 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6129
3 	xul.dll 	nsViewManager::HandleEvent 	view/src/nsViewManager.cpp:1202
4 	xul.dll 	xul.dll@0x435c5d 	
5 	xul.dll 	PresShell::DispatchSynthMouseMove 	layout/base/nsPresShell.cpp:4443
6 	xul.dll 	nsViewManager::ProcessSynthMouseMoveEvent 	view/src/nsViewManager.cpp:2197
7 	xul.dll 	nsSynthMouseMoveEvent::Run 	view/src/nsViewManager.cpp:2058
8 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
9 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
10 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:182
11 	nspr4.dll 	PR_GetEnv 	
12 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:110
13 	firefox.exe 	firefox.exe@0x21a7 	
14 	kernel32.dll 	kernel32.dll@0x13676 	
15 	ntdll.dll 	ntdll.dll@0x39d71 	
16 	ntdll.dll 	ntdll.dll@0x39d44
Summary: Crash occurs when clicking in the password field. → Crash [@ nsIFrame::HasView] occurs when clicking in the password field.
Looks like in PresShell::ClearMouseCapture, we're calling GetPrimaryFrame while a frame is being removed which causes problems.
Blocks: 503943
FWIW, I don't get a crash on this site.  If I click on the password field I get a popup saying "darn, you didn't enter your email or password".  Of course, I don't use the password manager, but the steps to reproduce don't mention that.  I am using the current hourly build below:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090921 Firefox/3.5.3 ID:20090921164632
I'm the one who originally reported this on Mozillazine forum (thanks, Gary, for confirming/filing this bug). For me, the crash didn't occur until I typed the first character of my password. Crash report is different from those above, identical on each of three crashes. Here's the latest one:

http://crash-stats.mozilla.com/report/index/6e5c4e89-4dd6-460c-a8c0-9f9222090921

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090921 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20090921050209
Attached file testcase
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #402078 - Flags: review?(roc)
Wonder if my crash is related?  I was over @ www.picfog.com and was typing in the search box and the latest Minefield build crashed. 

http://crash-stats.mozilla.com/report/index/0721cb97-be8f-425f-b833-8bc742090923
http://hg.mozilla.org/mozilla-central/rev/18d78af4be01
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Crash Signature: [@ nsIFrame::HasView]
You need to log in before you can comment on or make changes to this bug.