Closed Bug 518084 Opened 10 years ago Closed 9 years ago

test_browserGlue_prefs.js fails randomly with nsINavBookmarksService.getItemTitle]" nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"

Categories

(Firefox :: Bookmarks & History, defect, minor)

x86
Windows Server 2003
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: hsivonen, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [fixed-in-places])

Attachments

(1 obsolete file)

WINNT 5.2 mozilla-central test everythingelse on 2009/09/22 00:15:04 failed with
TEST-UNEXPECTED-FAIL | e:\builds\moz2_slave\mozilla-central-win32-unittest-everythingelse\build\xpcshell\tests\test_browser_places\unit\test_browserGlue_prefs.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.getItemTitle]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: e:/builds/moz2_slave/mozilla-central-win32-unittest-everythingelse/build/xpcshell/tests/test_browser_places/unit/test_browserGlue_prefs.js :: anonymous :: line 107"  data: no]
Unknown Error: command finished with exit code: 1

However, the push was related to video--not bookmarks--and the previous cycle was all green.
not explainable offhand, i have some patches in other bugs that touch these tests though.
Duplicate of this bug: 522802
Blocks: 438871
Whiteboard: [orange]
(In reply to comment #0)
> WINNT 5.2 mozilla-central test everythingelse on 2009/09/22 00:15:04

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1253603704.1253605727.19194.gz
OS: Windows XP → Windows Server 2003
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256102604.1256104404.969.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/10/20 22:23:24
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258193847.1258196201.25828.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/14 02:17:27
Whiteboard: [orange] → [orange][test_browserGlue_prefs.js disabled on central]
Whiteboard: [orange][test_browserGlue_prefs.js disabled on central] → [orange][test_browserGlue_prefs.js disabled on central][fixed-in-places]
test was cleaned up in central and lot of code changed, I assume this is WFM now.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange][test_browserGlue_prefs.js disabled on central][fixed-in-places] → [orange][fixed-in-places]
Whiteboard: [orange][fixed-in-places] → [fixed-in-places]
Attachment #8979715 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.