Show remote content button doesn't work in smart/unified inbox

NEW
Unassigned

Status

9 years ago
3 years ago

People

(Reporter: blassey, Unassigned)

Tracking

Trunk
x86
Windows 7
Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

When viewing messages in the smart inbox, clicking on the "Show Remote Content" button has no effect.  It works when viewing the message in its original folder though.
Flags: blocking-thunderbird3?
wfm in 20090922/WinXP (with what I think was a POP message in Local Folders, the only one I had with remote images today). By trunk do you mean a 20090921 or 20090922 3.0pre nightly, or a 3.1a1pre nightly, or something else?
UA: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20090922 Shredder/3.1a1pre

Upon further inspection, this applies to the "Not Junk" button as well. The "Ignore Warning" button works though.
Ah, genuine trunk. Don't suppose you'd like to step back to a 3.0pre nightly for a second, just to make sure your issue is (one of the many because we've been ignoring comm-central+mozilla-central while trying to ship off 1.9.1) only with 3.1 and not 3.0, and not just something I'm not using the right steps to see in 3.0?
sure thing, switching over to "Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4" I see the same thing.  I have an American airlines email in an gmail IMAP account, and clicking on the "Show Remote Content" seems to re-render the message, but still without the remote content.
also, the button doesn't go away after clicking it.
Anything in the error console?
no, unfortunately nothing in the error console.
This WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090928 Lightning/1.0pre Shredder/3.0pre

I sent myself a message with an embedded iframe which pointed to remote content, and viewed it in smart folders inbox (global and the account based one) and the show remote content button worked fine.

Therefore not blocking until we can get more people or clear STR on this. Also adding qawanted to try and get extra eyes on it.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Keywords: qawanted
this works for me now with:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090928 Shredder/3.0pre

should I resolve WFM or do people still want to investigate?  It was certainly an issue for about a week.
Let's close it as WFM. If we get the issue again we can always reopen it, but it also means we don't forget to close it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

9 years ago
Duplicate of this bug: 553256
Well,
this is still present with Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.8)
Gecko/20100216 Fedora/3.5.8-1.fc12 Firefox/3.5.8.
By the way I encounter this bug only with html email received on imap gmail account.

My original bug report 553256 has been marked as duplicated of this, but I think my original issue it's only gmail related.
It is not a general issue, like I said in its original description.

Comment 13

9 years ago
failed in safe mode Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8pre) Gecko/20100714 Lanikai/3.1.2pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Summary: Show remote content button doesn't work in smart inbox → Show remote content button doesn't work in smart/unififed inbox

Updated

8 years ago
Summary: Show remote content button doesn't work in smart/unififed inbox → Show remote content button doesn't work in smart/unified inbox

Comment 14

7 years ago
I'm on Mac and was about to file this same bug for TB 5. HOWEVER, I am not working in the smart inbox, I am working in a saved search folder that pulls from multiple email accounts.

NOTES:
 
(1) the Show Remote Content button doing nothing is NOT Windows-specific.
(2) At least on my computer the "Allows show remote content for [email]" link does not work either
(3) The "Add to Address Book" contextual menu item for the From address also does nothing.

I tested the Show button, the Always link, and the Add to Address Book cntxl menu item in Safe Mode, the problems still exist -- "nothing happens".

The only way to get the content to show or to add the From address to the address book is to switch to the Address Book pane, paste in the email, and check the "allow remote content" checkbox there.

Comment 15

7 years ago
sorry, my config details in case it matters:
TB 5.0 on Mac 10.6.8, Intel i7 Macbook Pro

Comment 16

6 years ago
I have a similar situation.

On TB 15.0.1 on my Windows 7y system the Show Remote Content button is missing on messages.  This happens whether the message is in the view pane or opened in a tab or new window.

However, the same messages on my XP system (same release of TB) has the button displayed and it works.

I tried restarting TB with addons disabled but that did not have any effect.

Comment 17

4 years ago
Confirming same issue under FC19 and TB 24.7.0, x86_64 (latest available via yum in FC19):

Under each account's inbox:

- Functionality as expected 

Under Unified Inbox:

- "Show Remote Content" does nothing.
- "Always allow remote content from ..." link *does* pop the contact window, but for the wrong/an existing contact, not for the email address from which the email came.
You need to log in before you can comment on or make changes to this bug.