Session cookies are not erased when user closes firefox

RESOLVED DUPLICATE of bug 443354

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 443354
10 years ago
8 years ago

People

(Reporter: bogdan, Unassigned)

Tracking

5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

Session cookies are live even after shutdown.

Reproducible: Always
Are you sure that you've closed ALL windows in Firefox (including minimized ones, dialogs, ...) ? If even a single one is open, you're not opening a new copy of Firefox, you're opening a new window in the existing Firefox. Also note that session cookies are shared among windows, unlike Internet Explorer (where they're confined to their own window).
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090922 Minefield/3.7a1pre

WFM
Yes, I'm sure. To be sure, I shutdown system.
Did you shut down the browser in a normal way ? If you kill the browser by shutting the computer, then the session cookies will be restored (on purpose).
Version: unspecified → 3.5 Branch
Reporter -> Are you still experiencing this issue with the latest version of Firefox 5?
Unfortunely, the answer is yes. (Firefox 5.0)
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile

What is your homepage setting?

Please provide exact steps to reproduce. i.e. open firefox, go to example.com, login, close firefox, open firefox, example.com session cookie still active
Version: 3.5 Branch → 5 Branch
I'm seeing this bug with Firefox 5.0.1 (Mac OS), even when starting with a new, empty profile, if I then change the Startup "When firefox starts" setting to "Show my windows and tabs from last time".

To reproduce:

start firefox 5.0.1 (on Mac OS 10.6.8) with a brand-new empty profile.
set "When firefox starts" to "Show my windows and tabs from last time".
go to example.com, and login.
quit firefox, wait for all windows to close.
re-start firefox.
observe that example.com session cookie is still active.
I guess this is a duplicate of bug 443354.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443354
You need to log in before you can comment on or make changes to this bug.