Page elements behavior in Linux version of firefox

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: ametedinov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-15])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

https://www.edline.net/Index.page - the text boxes are at different height on linux. It shows fine in windows. If you start typing in the username box on linux, you see only about 3/4 of the characters' top (you don't see the bottom of the typed character)

https://www.google.com/adsense/login/en_US/ - Google Adsense's site does not show properly on linux's firefox. Now you cannot say that this is bad coding because this is a billions $$ company and it CAN afford to hire the best web designers out there. Plus I emailed them about this issue long time ago and they don't / can't fix it.

There is probably an infinite number of websites I can list here that don't behave properly when opened via Firefox on Linux. 


Reproducible: Always




I am listing this as a Critical issue, for on some websites (not listed here) it prevents you from logging in because the username and password boxes are on top of one another for example. Or another situation is when you have a cluster of a dozen links and you cannot click the one you want because there are others on top of it. And similar situations have also occured to me in the past.

Why doesn't this type of problem occur in Windows?

Comment 1

9 years ago
In Firefox 3.5.4 and Mozilla/5.0 (X11; U; Linux i686; eo; rv:1.9.3a1pre) Gecko/20091104 Minefield/3.7a1pre,

I see "the text boxes are at different height on linux" and "Google Adsense's site does not show properly" only if full page zoom is disabled.

Do you have Full page zoom enable on Windows but disabled on Linux (View → Zoom → Zoom text only)?

I see "about 3/4 of the characters' top" with full page zoom. With text-only zoom it is worse, look at https://www.edline.net/css/index.css:

#screenName, #password {
	display: block;
	width: 200px;
	height: 15px;
	float: left;
}
(Reporter)

Comment 2

9 years ago
It looks like this is a bug that is not so obvious on Gnome because my main OS uses gnome and it works ok here. However, if you try what I've sayd in the first comment, using PartedMagic os ( www.partedmagic.com ) you get all of those problems. I am not sure which desktop environment parted magic uses, by the way. 

This behavior could be due to a bug in firefox, but the bug could also be somewhere else. Please try this WITH PartedMagic and let me know if this is a bug in firefox or something else. I will be very willing to help fix this 'ugly' behavior.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-15]
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.