UMR in nsReadingIterator<WORD>::normalize_forward(void)

VERIFIED DUPLICATE of bug 51662

Status

()

P3
normal
VERIFIED DUPLICATE of bug 51662
18 years ago
18 years ago

People

(Reporter: warrensomebody, Assigned: scc)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I'm seeing lots of these running the TestServMgr test program...

[W] UMR: Uninitialized memory read in 
nsReadingIterator<WORD>::normalize_forward(void) {1 occurrence}
    Reading 4 bytes from 0x0013fc30 (4 bytes at 0x0013fc30 uninitialized)
    Address 0x0013fc30 points into a thread's stack 
    Address 0x0013fc30 is 12 bytes past the start of local variable 'hashBegin' 
in NS_NewAtom(basic_nsAReadableString<WORD> const&)
    Thread ID: 0x8e
    Error location
        nsReadingIterator<WORD>::normalize_forward(void) 
[nsAReadableString.h:459]
                nsReadingIterator<CharT>::normalize_forward()
                  {
                    while ( mPosition == mFragment.mEnd
             =>          && mOwningString->GetReadableFragment(mFragment, 
kNextFragment) )
                        mPosition = mFragment.mStart;
                  }
                
        
basic_nsAReadableString<WORD>::BeginReading(nsReadingIterator<WORD>&)const 
[nsAReadableString.h:483]
        NS_NewAtom(basic_nsAReadableString<WORD> const&) [nsAtomTable.cpp:198]
        NS_NewAtom(char const*) [nsAtomTable.cpp:186]
        nsDirectoryService::Init(char const*) [nsDirectoryService.cpp:366]
        NS_InitXPCOM2(char const*,nsIServiceManager * *,nsIFile *) 
[nsXPComInit.cpp:252]
        NS_InitXPCOM(nsIServiceManager * *,nsIFile *) [nsXPComInit.cpp:200]
        NS_GetGlobalComponentManager(nsIComponentManager * *) 
[nsComponentManager.cpp:2290]
        nsComponentManager::RegisterComponent(nsID const&,char const*,char 
const*,char const*,int,int) [nsRepository.cpp:119]
        SetupFactories(void) [TestServMgr.cpp:142]
(Assignee)

Comment 1

18 years ago


*** This bug has been marked as a duplicate of 51662 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.