Notification bars are vertically pannable

VERIFIED WONTFIX

Status

Fennec Graveyard
General
--
major
VERIFIED WONTFIX
8 years ago
4 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
Build Id: 
Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2a2pre) Gecko/20090923 Fennec/1.0a3

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2a2pre) Gecko/20090923
Fennec/1.0b4pre

Steps to Reproduce:
1. Go to gmail
2. Login into gmail
3. With the resulting notification bar, try to pan horizontally and vertically

Actual Results:
I have no problem with the user panning horizontally as there are many proper use-cases for that, but I dont think the notification bar should be able to pan vertically as the emphasis is on the password/popup/whatever manager action.

Expected Results:
The notification bar is not vertically scrollable
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
Can you clarify?  Do you mean that the contents of the notification bar are scrollable, or do you mean the bar scrolls with the page and can go offscreen?
(Reporter)

Comment 2

8 years ago
Ah sorry, I meant that the bar scrolls with the page. None of the elements scroll on their own.
(In reply to comment #2)
> Ah sorry, I meant that the bar scrolls with the page. None of the elements
> scroll on their own.

This is as designed. The contents of the notification bar are not critical to the user using the webpage (i.e. the user can close the notification box and still use the page).

Also, how would the "non-scrolling" notification box work when the URLBar appears/disappears because the sidebars display?

We discussed this issue at length, I don't think we want to change the current behavior.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

8 years ago
With that reasoning, I'm verifying this as wontfix then. Thanks for the explanation.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.