Closed Bug 518366 Opened 13 years ago Closed 13 years ago

Clear search button shown when there are no recommended add-ons

Categories

(Firefox for Android Graveyard :: General, defect, P2)

x86
macOS
defect

Tracking

(fennec1.0+)

VERIFIED FIXED
fennec1.0b5
Tracking Status
fennec 1.0+ ---

People

(Reporter: madhava, Assigned: mfinkle)

Details

(Whiteboard: [polish] [fennec l10n])

Attachments

(1 file)

When there are no recommended add-ons that you don't have (this situation will get less common as more add-ons are in the recommended list), we surface the way that we're generating the recommended list:

http://www.flickr.com/photos/42739110@N07/3947223187/in/photostream/

We show a "clear search" button when the user never initiated a search (we did), and the results of clearing a search is to show the recommended list -- so, we end up back where we started with the "Clear Search" button.

Really, when there are no available recommended add-ons, we should say what Firefox does, which is "No recommended add-ons" (from memory).

That's a string I thought we had (because it's in firefox) but we may well not, in which case leave the space blank would be an in-between solution -- better than a clear button that doesn't do anything, but not quite as good as an explanation.
tracking-fennec: --- → ?
Whiteboard: [polish]
Priority: -- → P2
Can we just get rid of the text/clear button if there are no recommendations?
tracking-fennec: ? → 1.0+
What if the user wants to try looking for recommended add-ons again?
Attached patch patchSplinter Review
This patch adds new strings for the "No recommended add-ons" message and the "Try Again" button. It also changes "Clear search" to "Clear Search" (Title case for button captions)

In order to get the "no recommended" situation to happen, I had to trick the AMO service. I changed my "extensions.getAddons.recommended.url" preference to:

"https://services.addons.mozilla.org/%LOCALE%/mobile/api/%API_VERSION%/list/featured/all/10/%OS%/0.1"

Which yielded this screenshot:
http://people.mozilla.com/~mfinkle/fennec/screenshots/fennec-no-recommended.png

Yes, I think we need to give people a way to "try again", which is a problem we had ourselves during testing. Connection problems could cause Fennec to start and the user to look for add-ons without a connection or some other issue. Having a "Try Again" button is just a comfort tool for the user.
Assignee: nobody → mark.finkle
Attachment #407684 - Flags: review?(gavin.sharp)
Flags: in-litmus?
Whiteboard: [polish] → [polish] [fennec l10n]
Comment on attachment 407684 [details] [diff] [review]
patch

>diff --git a/locales/en-US/chrome/browser.properties b/locales/en-US/chrome/browser.properties

>-addonsSearchSuccess.button=Clear search
>+addonsSearchSuccess.button2=Clear Search

I think it's better to put the number on the first part and leave the context-description as-is, so addonsSearchSuccess2.button .
Attachment #407684 - Flags: review?(gavin.sharp) → review+
(In reply to comment #4)

> >-addonsSearchSuccess.button=Clear search
> >+addonsSearchSuccess.button2=Clear Search
> 
> I think it's better to put the number on the first part and leave the
> context-description as-is, so addonsSearchSuccess2.button .

Yeah, makes sense
Target Milestone: --- → B5
pushed:
https://hg.mozilla.org/mobile-browser/rev/5b8aa669c6b0
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20091026
Fennec/1.0b5pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20091026
Fennec/1.0b5pre
Status: RESOLVED → VERIFIED
I've purposefully turned off my network connection in order to try to see what this looks like when fixed in order to write a test case. I can't seem to get an empty list of suggested add-ons. Is there a way to override things in about:config to force that state?
Hm, I tried clearing the recommendedurl in about:config and that forced an indefinite search of recommended addons (at least shown in the UI). 

Mark, would you have any suggestions on how to force an empty list of suggested add-ons?
litmus testcase https://litmus.mozilla.org/show_test.cgi?id=7166 has been updated to regression test this bug.
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.