Firefox will not open links in external programs, even though I have it set to default web browser.

RESOLVED DUPLICATE of bug 502572

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 502572
9 years ago
8 years ago

People

(Reporter: nko12, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB5 (.NET CLR 3.5.30729)

(MOST of the time) whenever i try to open a link from an external program (window's OneNote, outlook, Xfire, Lightscribe, a game that has links you can click on) it will NOT open them. In fact, nothing happens at all. Is there any way to fix this? (And no, the links are not wrong)

P.S Could someone also tell me how to actually apply patches from this website? I see all these patches that could fix problems, but nothing tell me HOW to apply them.

Reproducible: Always

Actual Results:  
Nothing

Expected Results:  
A tab to open to whatever link I clicked on in the external program.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090922 Minefield/3.7a1pre

I opened successfully a Metapad link with the default browser and the default profile. 
So install Firefox and set as default browser, create a new profile and use as default. If this works, there was something wrong with your set-up.
Support can help you how to find the cause: http://support.mozilla.com/

If you want to apply patches, you need the Mercurial software AFAIK.
https://developer.mozilla.org/en/Mercurial
Version: unspecified → 3.5 Branch
Setting Firefox as default browser: Tools > Options > Advanced > General > System Defaults.
(Reporter)

Comment 3

9 years ago
I figured that was the problem, but unfortunately Firefox IS my default search browser. Although...after a little more experimenting, Outlook is the ONLY program that can open links into Firefox, while Firefox does nothing when all the other programs try to open anything... I only suspect its Firefox because I cannot open links from any programs (other than outlook) most of the times...but when I CAN open links, I can open from all of them. basically, I can easier open a link from the programs or I can't open it from the programs...
(Reporter)

Updated

9 years ago
Summary: Firefox opens links activated by external programs randomly and usually will do nothing. → Firefox will not open links in external programs, even though I have it set to default web browser.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 502572
You need to log in before you can comment on or make changes to this bug.