If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

One product and no components -> crash

VERIFIED DUPLICATE of bug 40987

Status

()

Bugzilla
Bugzilla-General
P3
minor
VERIFIED DUPLICATE of bug 40987
17 years ago
5 years ago

People

(Reporter: Andreas Buschka, Assigned: justdave)

Tracking

Details

(Reporter)

Description

17 years ago
I installed Bugzilla within my company. It works fine, but there is one trap 
that should be put out of the way: I entered a product and forgot to define 
components (the product does not have any). Then I tried to enter a bug and got:

Content-type: text/html 

Software error:

Can't use string ("") as an ARRAY ref while "strict refs" in use 
at /usr/local/httpd/bugzilla/enter_bug.cgi line 240. 

For help, please send mail to the webmaster (root@localhost), giving this error 
message and the time and date of the error. 

I think this should be prevented.
I could swear this was fixed a long time ago...   yep.  Bug 40987.  What version 
of Bugzilla are you running?  I suspect it's something older than 2.11.
(Reporter)

Comment 2

17 years ago
I am using version 2.10 (ftp://ftp.mozilla.org/pub/webtools/bugzilla-
LATEST.tar.gz). Time for a new release?
2.11 is available via cvs.  See http://www.mozilla.org/cvs.html for 
instructions 
how to get it.  Only the even numbered versions get tarballed.  2.12 will 
probably be tarballed in about a month or so, but depends on the last bugs 
getting nailed.  You can search this bugzilla for open bugs with a status 
whiteboard value of "2.12" to see what's been decided needs to be finished 
before the 2.12 tarball is made.

In the meantime, you can get a patch to fix this particular bug here:
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=9717
if you don't feel like retrieving the CVS version.

*** This bug has been marked as a duplicate of 40987 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified dupe of fixed bug 40987: "Error message when no components are defined
for a product."
Status: RESOLVED → VERIFIED
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.