sharedobj.dll loads only when I load FF. Every 5-10 minutes it crashes Firefox.

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: info, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

There is a file on my system called sharedobj.dll in system32. I have tried to delete this, uninstalled FF in safe mode, reinstalled FF in safe mode.

Here is a copy of the aplication l;ogf file. Any ideas are appreciated.

Faulting application firefox.exe, version 1.9.1.3523, faulting module sharedobj.dll, version 0.0.0.0, fault address 0x00008691.

The application, C:\Program Files\Mozilla Firefox\firefox.exe, generated an application error The error occurred on 09/24/2009 @ 18:51:22.997 The exception generated was c0000005 at address 054A8629 (<nosymbols>)



Reproducible: Always

Steps to Reproduce:
1. Start FireFox
2. withn 5-10 minutes of web browsing, crashes
3. No consistency in crashing. Just random event.
Actual Results:  
See above
(Reporter)

Comment 1

9 years ago
Created attachment 402569 [details]
this is the error report generated.

Happend again. just now. . its so frustrating.

Crashing FF everytime
(Reporter)

Comment 2

9 years ago
It appears to happen more frequently qhen I am logged onto a secure site https//
(Reporter)

Comment 3

9 years ago
Anyone has any suggestions. I have uninstalled FF in safe mode. Reinstalled, removed previous user profiles etc.
(Reporter)

Comment 4

9 years ago
Anyone?
There's very little information I could find about sharedobj.dll, but it appears to be causing a lot of IE8 users problems, too and may be malware. Since sharedobj.dll doesn't come with Firefox I would not expect reinstalling Firefox to help.

If you could attach a copy of the file to this bug report we could investigate it. You could also upload it to http://www.virustotal.com/ and see what they say about it. If not that'll be the first thing I try with it.
Group: core-security

Comment 6

9 years ago
the many links off of this set of search results tell of people having problems with shareobj.dll

http://www.google.com/search?q=sharedobj.dll&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

some have suggestions on procedures that might help to remove.
Blocks: 512788
(Reporter)

Comment 7

9 years ago
I no longer have this issue. The problem seemed to go away when certain plugins were removed or an update was reversed. I remember getting an email from Mozilla about a conflict with a Microsoft plugin or similar and it was removed by Mozilla.

Comment 8

9 years ago
for the record,

https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

however, since you're happy, "WORKSFORME"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.