Get Mail toolbar button not display "get all new messages" item after customising toolbar

RESOLVED FIXED in Thunderbird 3.0rc1

Status

defect
P2
minor
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Aureliano, Assigned: bwinton)

Tracking

({regression})

Thunderbird 3.0rc1
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

Attachments

(1 attachment)

Reporter

Description

10 years ago
Usually "Get Mail" toolbar button, display n items:

---------------------
get all new messages |
---------------------
account 1            |
...                  |
account n            |
---------------------

But if I open the window for customize toolbar "get all new messages" disappair.

STR:
1. rx click on toolbar and select "custumize..."
2. on "customize toolbar" window click done button.

goto "Get Mail" toolbar button: "get all new messages" is ghost.

When restart TB, all is fine.

I cannot find any dupe.


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090924 Lightning/1.0pre Shredder/3.0pre ID:20090924031806
It's dup that as just been fixed
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 516353
Reporter

Comment 3

10 years ago
According to Mark Banner in bug #516353#c23, this bug is reopen.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Reporter

Updated

10 years ago
Status: REOPENED → NEW
Clarifying title as it only happens *after* customising the toolbar.
Summary: Get Mail toolbar button not display "get all new messages" item → Get Mail toolbar button not display "get all new messages" item after customising toolbar
Reporter

Comment 5

10 years ago
Confirmed also today in

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090930 Lightning/1.0pre Shredder/3.0pre ID:20090930031731

See STR in comment #0

It's a TB3 blocker?
Flags: blocking-thunderbird3?
Should probably be fixed.
Assignee: nobody → bwinton
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Assignee

Updated

10 years ago
Priority: -- → P2
Whiteboard: [no l10n impact]
The only sane way I could figure out to fix this is to keep track of the children we've created, and only remove those on _teardown.

Thanks,
Blake.
Attachment #404841 - Flags: superreview?(bienvenu)
Attachment #404841 - Flags: review?(bugmail)
Assignee

Updated

10 years ago
Whiteboard: [no l10n impact] → [no l10n impact][patch up, needs r/sr]
Blocks: 520457

Comment 8

10 years ago
Comment on attachment 404841 [details] [diff] [review]
Keep track of which children we added, and only remove those.

I don't know if there's a better way to do this, but it looks OK.
Attachment #404841 - Flags: superreview?(bienvenu) → superreview+
Assignee

Updated

10 years ago
Whiteboard: [no l10n impact][patch up, needs r/sr] → [no l10n impact][patch up, needs r]
OS: Windows XP → All
Hardware: x86 → All
Attachment #404841 - Flags: review?(bugmail) → review+
Assignee

Updated

10 years ago
Keywords: checkin-needed
Whiteboard: [no l10n impact][patch up, needs r] → [no l10n impact]
http://hg.mozilla.org/comm-central/rev/a470766f312b
Status: NEW → RESOLVED
Last Resolved: 10 years ago10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0rc1
You need to log in before you can comment on or make changes to this bug.