Last Comment Bug 518647 - Deleted and re-added RSS feed fails to work correctly (possibly at all).
: Deleted and re-added RSS feed fails to work correctly (possibly at all).
Status: RESOLVED DUPLICATE of bug 254230
:
Product: MailNews Core
Classification: Components
Component: Feed Reader (show other bugs)
: 1.9.1 Branch
: x86 Windows XP
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-24 12:37 PDT by Etan Reisner
Modified: 2011-03-27 05:01 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
feeditems.rdf - containing references to fora (171.90 KB, text/plain)
2009-10-19 06:15 PDT, Ludovic Hirlimann [:Usul]
no flags Details

Description Etan Reisner 2009-09-24 12:37:37 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

An RSS feed that has been deleted and then re-added will fail to properly download new feed items, fail to display all feed items listed in feeditems.rdf, and fail to update (at least when "Get Messages") is selected.

This failure consists of thunderbird not even attempting to make an http connection (wireshark shows no traffic when the feed is re-added and when Get Messages is selected despite Thunderbird claiming it is checking for new messages and, during re-add, finding items).

Reproducible: Always

Steps to Reproduce:
1. Add an RSS feed, see that it has items.
2. Delete the RSS feed and remove it from the Trash.
3. Re-add the feed, see that Thunderbird lists the correct number of items in the status bar as being found/downloaded/etc.
4. Check the feed folder, see only one item listed.
5. Open wireshark, set to capture traffic.
6. Right-click the feed entry in the folder list and select "Get Messages" notice that nothing appears to happen.
7. Check wireshark and see that no HTTP traffic was generated by thunderbird.
Actual Results:  
The feed remained broken, items remained in feeditems.rdf that were not shown in the thunderbird interface, it is not at all clear how to correctly resolve this situation (short of deleting feeditems.rdf entirely, which may or may not work I don't really know and I certainly don't know what side-effects that might also have).

Expected Results:  
The feed should display correctly, including both old and new items.

I discovered this in my default profile, but tested specifically in an empty profile as well. The feed I originally discovered this with was already broken (I had not seen updates for it in ages and was attempting to verify if that was because the feed was in fact dormant or not). I am willing to provide any further information that might be necessary, just let me know.

I saw at least two possibly related bugs but their age, general lack of information, and lack of movement made me wary of commenting on them as opposed to filing a new ticket, my apologies if that was incorrect.
Comment 1 Ludovic Hirlimann [:Usul] 2009-09-25 02:13:07 PDT
Anything in Tools -> Error console when you re-add the feed ?

If you restart thunderbird does the issue go away ?

I suppose you also tested in safe-mode ?
Comment 2 Ludovic Hirlimann [:Usul] 2009-09-25 02:19:33 PDT
confirming on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090923 Shredder/3.0pre.
Comment 3 Ludovic Hirlimann [:Usul] 2009-09-25 08:37:16 PDT
after a restart however my Feed started working again.
Comment 4 Etan Reisner 2009-09-25 09:46:56 PDT
One item in the error console when I try to re-add the feed:

"2009-09-25 12:30:41	gloda.datastore	ERROR	got error in _asyncTrackerListener.handleError(): 19: constraint failed"

No, restarting doesn't seem to fix the problem (both in my normal profile and in the test profile). What exactly about it was working again after you restarted (did Get Messages cause traffic, did new items show up, did the correct amount of older items show up)? Just trying to make sure we are looking at the same things.

A quick try in safe mode with a test profile behaved the same as without safe mode (which I rather expected as my test profile had no add-ons, themes, etc.).

The test profile displayed one additional error (though only once so I'm not sure if it is material):

"2009-09-25 12:37:08	gloda.indexer	WARN	Problem during [job:folder delta:0 id:1 items:0 offset:39 goal:50], trying to recover.  Problem was at undefined:2538: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgDBHdr.messageId]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Thunderbird%203.0%20Beta%204/modules/gloda/indexer.js :: gloda_indexMessage :: line 2538"  data: no]"
Comment 5 Ludovic Hirlimann [:Usul] 2009-09-27 23:55:22 PDT
(In reply to comment #4)
> One item in the error console when I try to re-add the feed:

> restarted (did Get Messages cause traffic, did new items show up, did the
> correct amount of older items show up)? Just trying to make sure we are looking

I'm getting new feed items.
Comment 6 Etan Reisner 2009-10-01 11:13:51 PDT
The feed I encountered this with (in my actual profile) has not received any updates since being re-added nor has it started to show the other entries that still exist in feeditems.rdf.

I wonder if perhaps the type of feed might matter here, the feed I'm seeing this with is the feed from fora.tv (I'm not up enough of how to visually identify the various flavors of feed from their XML enough to know which type that is offhand).
Comment 7 Ludovic Hirlimann [:Usul] 2009-10-05 04:12:09 PDT
(In reply to comment #6)

> I wonder if perhaps the type of feed might matter here, the feed I'm seeing
> this with is the feed from fora.tv (I'm not up enough of how to visually
> identify the various flavors of feed from their XML enough to know which type
> that is offhand).

Can you give us the feed URL ?
Comment 8 Etan Reisner 2009-10-05 07:48:35 PDT
The main feed for the site (http://fora.tv/RSS/fora_rss). Sorry, I suppose I could have made that clearer.
Comment 9 Ludovic Hirlimann [:Usul] 2009-10-06 23:50:10 PDT
(In reply to comment #8)
> The main feed for the site (http://fora.tv/RSS/fora_rss). Sorry, I suppose I
> could have made that clearer.

With that I can reproduce. When removing the feed, a few items are left in feeditems.rdf - which might be the cause of this issue. Shall I attach the file ?
Comment 10 Etan Reisner 2009-10-13 10:57:55 PDT
You weren't asking me about that were you? (I don't think you were but just wanted to be sure you weren't waiting on me for an answer.)
Comment 11 Ludovic Hirlimann [:Usul] 2009-10-14 01:13:42 PDT
(In reply to comment #10)
> You weren't asking me about that were you? (I don't think you were but just
> wanted to be sure you weren't waiting on me for an answer.)

No , I was asking Myk. I should be way more precise when I write in bugzilla.
Comment 12 Myk Melez [:myk] [@mykmelez] 2009-10-19 05:02:11 PDT
Ludovic: if it doesn't contain any personal information, then yes, please do attach the file!
Comment 13 Ludovic Hirlimann [:Usul] 2009-10-19 06:15:50 PDT
Created attachment 407014 [details]
feeditems.rdf - containing references to fora
Comment 14 Pádraig Brady 2010-12-03 15:51:46 PST
Same here with version 3.0.3
I think this is just a simple matter of items not being removed from feeditems.rdf when the folder is deleted.
I wanted to delete a folder and resubscribe, so I needed to delete the items from feeditems.rdf manually. Pain in the a..
Comment 15 [:Aureliano Buendía] 2011-03-27 05:01:10 PDT

*** This bug has been marked as a duplicate of bug 254230 ***

Note You need to log in before you can comment on or make changes to this bug.