Edit links in PTO table go to 404

RESOLVED FIXED

Status

mozilla.org
Webdev
--
major
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Waldo, Assigned: fox2mike)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
See URL.

Comment 1

9 years ago
I see that this is due to me having forgotten to do svn add on edit.php. It is now in r52322.
Assignee: nobody → shyam
(Assignee)

Comment 2

9 years ago
[root@mrapp-intranet01 intranet.mozilla.org-pto]# svn up
U    css/style.css
U    index.php
U    templates/footer.php
U    templates/header.php
A    edit.php
Updated to revision 52322.
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Duplicate of this bug: 515773
It this actually fixed?

Comment 5

8 years ago
I believe so, since https://intranet.mozilla.org/pto/edit.php now exists.
Wilson - when we try to edit PTO even before the start of the PTO period, it says we don't have permissions.  Can you take a look at this please?
Assignee: shyam → kourge
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

8 years ago
Does this occur only if you adjust the starting date to an earlier one rather than a later one? I've fiddled around with my working copy on khan and there doesn't seem to be anything that should manifest this strange behavior.

Is the exact error message "Not authorized."? Does the same thing happen to the copy on khan?
http://kourge.khan.mozilla.org/pto/
Yeah, if I set something for the future and try to edit it I get this message every time:
You cannot edit this PTO entry due to one of the following:

    * You are not the one who submitted this PTO entry.
    * It is now past the end of the PTO.
    * You just don't have enough power. Ask someone from HR.

Comment 9

8 years ago
It seems like this was due to a stray quotation mark in the constructed MySQL query string. After the fix (on khan and now committed to SVN) the feature appears to work fine now.
OK.  Thanks Wilson.  Shyam - could you update the intranet PTO app again please?
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

8 years ago
[root@mrapp-intranet01 intranet.mozilla.org-pto]# svn up
U    submit.php
U    edit.php
Updated to revision 55161.

Done.
Assignee: kourge → shyam
You need to log in before you can comment on or make changes to this bug.