Closed Bug 518667 Opened 11 years ago Closed 11 years ago

crash [@ nsImapMailFolder::UpdateFolderWithListener(nsIMsgWindow*, nsIUrlListener*)]

Categories

(MailNews Core :: Networking: IMAP, defect, critical)

1.9.1 Branch
x86
All
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: wsmwk, Assigned: rkent)

Details

(Keywords: crash, regression, topcrash)

Crash Data

Attachments

(1 file)

crash [@ nsImapMailFolder::UpdateFolderWithListener(nsIMsgWindow*, nsIUrlListener*)]

currently #3 3.0b4 crash, but too early yet to say if this will stay there.
not seen in 3.0b3, b3pre or b4pre

biff related?

all the windows crashes are 0x0 address
bp-5ec16667-385b-4450-a1e7-6a3722090924
0	thunderbird.exe	nsImapMailFolder::UpdateFolderWithListener	 mailnews/imap/src/nsImapMailFolder.cpp:787
1	thunderbird.exe	nsImapMailFolder::UpdateFolder	mailnews/imap/src/nsImapMailFolder.cpp:690
2	thunderbird.exe	nsImapMailFolder::GetNewMessages	mailnews/imap/src/nsImapMailFolder.cpp:2580
3	thunderbird.exe	nsImapIncomingServer::PerformBiff	mailnews/imap/src/nsImapIncomingServer.cpp:981
4	thunderbird.exe	nsMsgBiffManager::PerformBiff	mailnews/base/src/nsMsgBiffManager.cpp:343
5	xpcom_core.dll	nsTimerImpl::Fire	xpcom/threads/nsTimerImpl.cpp:420
6	xpcom_core.dll	nsTimerEvent::Run	xpcom/threads/nsTimerImpl.cpp:512
7	xpcom_core.dll	nsThread::ProcessNextEvent	xpcom/threads/nsThread.cpp:521
8	xpcom_core.dll	NS_ProcessNextEvent_P	objdir-tb/mozilla/xpcom/build/nsThreadUtils.cpp:227
9	thunderbird.exe	nsBaseAppShell::Run	widget/src/xpwidgets/nsBaseAppShell.cpp:170
10	thunderbird.exe	nsAppStartup::Run	toolkit/components/startup/src/nsAppStartup.cpp:193
11	thunderbird.exe	XRE_main	toolkit/xre/nsAppRunner.cpp:3321
12	thunderbird.exe	NS_internal_main	mail/app/nsMailApp.cpp:103
13	thunderbird.exe	wmain	toolkit/xre/nsWindowsWMain.cpp:110
14	thunderbird.exe	__tmainCRTStartup	objdir-tb/mozilla/memory/jemalloc/src/crtexe.c:591
15	kernel32.dll	BaseThreadInitThunk	


none of the Mac crashes are 0x0
bp-048f1cf1-6818-4868-b7d3-d6b332090923
Frame	Module	Signature [Expand]	Source
0	thunderbird-bin	nsImapMailFolder::UpdateFolderWithListener	mailnews/imap/src/nsImapMailFolder.cpp:787
1	thunderbird-bin	nsImapMailFolder::UpdateFolder	mailnews/imap/src/nsImapMailFolder.cpp:690
2	thunderbird-bin	nsImapMailFolder::GetNewMessages	mailnews/imap/src/nsImapMailFolder.cpp:2580
3	thunderbird-bin	nsImapIncomingServer::PerformBiff	mailnews/imap/src/nsImapIncomingServer.cpp:981
4	libxpcom_core.dylib	NS_InvokeByIndex_P	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_unixish_x86.cpp:179
5	thunderbird-bin	XPCWrappedNative::CallMethod	js/src/xpconnect/src/xpcwrappednative.cpp:2454
6	thunderbird-bin	XPC_WN_CallMethod	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1590
7	libmozjs.dylib	js_Invoke	js/src/jsinterp.cpp:1386
8	libmozjs.dylib	js_Interpret	js/src/jsinterp.cpp:5179
9	libmozjs.dylib	js_Invoke	js/src/jsinterp.cpp:1394
10	libmozjs.dylib	js_InternalInvoke	js/src/jsinterp.cpp:1447
11	libmozjs.dylib	JS_CallFunctionValue	js/src/jsapi.cpp:5187
12	thunderbird-bin	nsJSContext::CallEventHandler	dom/src/base/nsJSEnvironment.cpp:2085
13	thunderbird-bin	nsGlobalWindow::RunTimeout	dom/src/base/nsGlobalWindow.cpp:7843
14	thunderbird-bin	nsGlobalWindow::TimerCallback	dom/src/base/nsGlobalWindow.cpp:8177
looks like customTerm might be null - thought I saw a patch for that - did it not make b4?
nsMsgFilterService::GetCustomTerm returns null but rv of NS_OK, so I can see why this crashes...should be trivial to fix.
Flags: blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0rc1
customTerm->GetNeedsBody is new code, using a new idl method that was
implemented in bug 127250 on Sept 4.

I think this is just the same mistake in new code, where I ignored the comment
in GetCustomTerm that a missing term will give a null result, assumming it
would throw an error instead.

Maybe I should change the root cause, since I've now made the same mistake
twice - and I am the one who wrote it that way in the first place!

Anyway, I'll fix this.
Assignee: nobody → kent
Status: NEW → ASSIGNED
Attachment #402667 - Flags: superreview?(bienvenu)
Attachment #402667 - Flags: review?(bienvenu)
Attachment #402667 - Flags: approval-thunderbird3?
Attachment #402667 - Flags: superreview?(bienvenu)
Attachment #402667 - Flags: superreview+
Attachment #402667 - Flags: review?(bienvenu)
Attachment #402667 - Flags: review+
Attachment #402667 - Flags: approval-thunderbird3?
Attachment #402667 - Flags: approval-thunderbird3+
Comment on attachment 402667 [details] [diff] [review]
check for null customTerm

looks good, thx.
Checked in http://hg.mozilla.org/comm-central/rev/3d051e65f377.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Crash Signature: [@ nsImapMailFolder::UpdateFolderWithListener(nsIMsgWindow*, nsIUrlListener*)]
You need to log in before you can comment on or make changes to this bug.