Multiple events being thrown instead of single event

RESOLVED WONTFIX

Status

()

P3
major
RESOLVED WONTFIX
18 years ago
15 years ago

People

(Reporter: ckritzer, Assigned: sfraser_bugs)

Tracking

({platform-parity})

Trunk
Future
PowerPC
Mac System 8.6
platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbetadenied], URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Overview:  When regressing bugzilla#45368, I noticed the MacOS was throwing 
multiple mouseover events (sometimes two, usually three).  This is 'bad'.

Steps to Reproduce:
1) Load http://bugzilla.mozilla.org/showattachment.cgi?attach_id=11336
2) Mouse over any of the four tree images

Expected Results:  Only 1 javascript alert which says 'I am the IMG'

Actual Results:  Two or three javascript alerts.

Platforms tested on:
- LinuxRH62 2000-09-07-08-M18 Commercial
- Win98     2000-09-07-08-M18 Mozilla
- MacOS86   2000-09-07-04-M18 Commercial
(Reporter)

Comment 1

18 years ago
PDT: Nominating for nsbeta3+
Reason:  High visibility, platform parity, just plain bad <wink>
Keywords: nsbeta3, pp
I will do some initial investigation, I have a hunch this is a duplicate of some 
stuff (images using timers instead of normal event queue).
Assignee: joki → heikki
Created attachment 14625 [details]
Modified testcase 1, show events in document
Created attachment 14626 [details]
Modified testcase 2, replaced images with text, show events in doc
I am lowering severity to major, this is not a crasher.

I attached two new testcases. If either of them works correctly on a Mac, this 
might be a duplicate of bug 52209.
Severity: critical → major
This is probably a dup of bug 45309, which was nsbeta3+ but was marked
WORKSFORME. If this is indeed a dup, and it was working at some point, this is
also a regression. Btw, that bug has absolutely beautiful testcases!

After some more testing I found that this really only happens on the Mac.
pinkerton and saari are seeing this.

Also, you see the bug only with alert boxes. I have made modified testcases for
this bug and for bug 45309 which write the message into the document to avoid
alert box, and they have a counter which increments each time a message is
written. With these modified test cases you do not see this bug, which suggests
the real bug is that we get too many alert boxes. Bug 52209 is about that, so I
am reassigning this to danm.
Assignee: heikki → danm

Comment 7

18 years ago
-> Future. If only on alert(), then this doesn't fit the nsbeta3 p1/p2 criteria
Target Milestone: --- → Future

Comment 8

18 years ago
nsbeta3-
Whiteboard: [nsbeta3-]

Comment 9

18 years ago
Updating QA Contact.
QA Contact: janc → lorca

Comment 10

18 years ago
Changing Status for my reference.  Was NSBETA3-.
Whiteboard: [nsbeta3-] → [nsbetadenied]
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
Keywords: nsdogfood
nominating for dogfood (from sdagley's list of bugs that are good candidates for 
our next release) 
Keywords: nsCatFood
Keywords: nsdogfood

Comment 13

18 years ago
QA contact updated
QA Contact: gerardok → madhur

Updated

17 years ago
QA Contact: madhur → rakeshmishra

Updated

16 years ago
QA Contact: rakeshmishra → trix
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Comment 15

15 years ago
I'm a bad owner for this bug since I no longer have access to a Mac. So I'm
dumping it on sfraser. Simon, this bug is scheduled to be resolved. It could
stand to be saved if it's still a problem, which it could be even on OS X.
Assignee: danm-moz → sfraser
WFM on Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a)
Gecko/20031013, marking WONTFIX because we no longer support mac classic.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.