Do not need to send return receipts to yourself when viewing your sent mails.

RESOLVED DUPLICATE of bug 257406

Status

RESOLVED DUPLICATE of bug 257406
9 years ago
9 years ago

People

(Reporter: hgj, Unassigned)

Tracking

x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.2) Gecko/20090730 SUSE/3.5.2-1.2 Firefox/3.5.2
Build Identifier: version 2.0.0.23 (20090817)

When you open a mail that you sent with a request to return the notification when the recipient has read it, Thunderbird ask you or actually send the notification back to the sender, that is you. In that way you keep getting read notifications from yourself after reading your sent mail.

Reproducible: Sometimes

Steps to Reproduce:
1. Send a message with the request to a return receipt (read notification)
2. Open the mail in your sent folder

Actual Results:  
a) Thunderbird asks you to send the receipt to yourself
b) You'll get a read notification after you read your own sent mail

Expected Results:  
Thunderbird should notice, that the sender is one of the Accounts set up, so it does not need to send the receipt.

Thunderbird does not do this always. I did not manage, to find a pattern, when it does it. It asks me to send the notification the 5th time I read that mail, and sometimes the 1st time. (It might ask more than once for one mail, but I could not track that, so I'm not sure)

Header of two mails when Thunderbird asked to send/sent the notification:

Message-ID: <4A94447A.5060806@nagyterv.hu>
Disposition-Notification-To: =?UTF-8?B?IkhvcnbDoXRoIEdlcmdlbHkgSi4i?=
 <hgj@nagyterv.hu>
Date: Tue, 25 Aug 2009 22:07:22 +0200
From: =?UTF-8?B?IkhvcnbDoXRoIEdlcmdlbHkgSi4i?= <hgj@nagyterv.hu>
Organization: Nagy Terv =?UTF-8?B?SWZqw7pzw6FnaSBLw7ZybnllemV0IMOpcyBUZXJt?=
 =?UTF-8?B?w6lzemV0dsOpZGVsbWkgUHJvZ3JhbQ==?=
User-Agent: Thunderbird 2.0.0.23 (X11/20090817)
MIME-Version: 1.0
To: =?UTF-8?B?WnN1enNhIFRha8OhdHM=?= <takatszsuzsa@gmail.com>
Subject: Re: Mi finomat =?UTF-8?B?ZsWRenplayBuZWtlZD8=?=
References: <21b8d39f0908251125n3e971826kfdf330294ac9aaef@mail.gmail.com>
In-Reply-To: <21b8d39f0908251125n3e971826kfdf330294ac9aaef@mail.gmail.com>
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Message-ID: <4ABBE4DF.7080902@nagyterv.hu>
Disposition-Notification-To: =?UTF-8?B?IkhvcnbDoXRoIEdlcmdlbHkgSi4i?=
 <hgj@nagyterv.hu>
Date: Thu, 24 Sep 2009 23:30:07 +0200
From: =?UTF-8?B?IkhvcnbDoXRoIEdlcmdlbHkgSi4i?= <hgj@nagyterv.hu>
Organization: Nagy Terv =?UTF-8?B?SWZqw7pzw6FnaSBLw7ZybnllemV0IMOpcyBUZXJt?=
 =?UTF-8?B?w6lzemV0dsOpZGVsbWkgUHJvZ3JhbQ==?=
User-Agent: Thunderbird 2.0.0.23 (X11/20090817)
MIME-Version: 1.0
To: =?UTF-8?B?VGFrw6F0cyBNw7NuaWth?= <takatsmonika@nagyterv.hu>
Subject: Re: =?UTF-8?B?dmFzw6FybmFw?=
References: <34941.67.85.190.170.1253822859.squirrel@levelezes.ultrabay.hu>    <4ABBD3FD.7040607@nagyterv.hu> <35313.67.85.190.170.1253825127.squirrel@levelezes.ultrabay.hu>
In-Reply-To: <35313.67.85.190.170.1253825127.squirrel@levelezes.ultrabay.hu>
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
(Reporter)

Updated

9 years ago
Version: unspecified → 2.0
Is <hgj@nagyterv.hu> defined as main identity of account who owns mail folder in which the mail is held?

If non-main identity, it's probably Bug 257406.
If identity of other account, it's design, and it's required action.
If main identity of account who owns mail folder in which the mail is held main identity of identity of other account, it's possibly similar issue to Bug 516325(I can't reproduce the problem with no add-on).  

> Thunderbird ask you or actually send the notification back to the sender, that is you.

Does it mean that Tb doesn't always ask for "send notification back"?
Does Tb send back it silently in some cases?
(Reporter)

Comment 2

9 years ago
The only place I managed to reproduce the problem (to make it easier) is on account A, where at the identities, an other B mail address is defined.
When the problem occurs, the mail I'm viewing is from B (not the main identity).

I guess I wrote a duplicate of 257406.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 257406
You need to log in before you can comment on or make changes to this bug.