Create alias that redirects to an AMO search for add-ons

RESOLVED FIXED in 3.0rc1

Status

RESOLVED FIXED
9 years ago
3 months ago

People

(Reporter: davida, Assigned: gozer)

Tracking

unspecified
3.0rc1
Bug Flags:
blocking-thunderbird3 +

Details

(Whiteboard: [no l10n impact])

(Reporter)

Description

9 years ago
In bug 516884, we will introduce UI that wants to point people to a specific search on AMO.  In order to be robust w.r.t. any possible changes in AMO's HTTP API, domain, etc., we want to have a URL on a momo website which takes a URL w/ query parameters from Thunderbird, and redirects the user to an appropriate page.

Proposal:

Thunderbird will point to something like:

  https://live.mozillamessaging.com/thunderbird/addons?search=header&version=3.0&locale=en-US

which would redirect to:

  https://addons.mozilla.org/en-US/thunderbird/search?q=header&appid=18hver=3.0&lver=3.0

obviously "en-US", "header", and "3.0" might vary.

I'm not sure whether we will ever want thunderbird to specify different values for hver and lver.  I kinda think not.

(we have an immediate need for the specific 'header' search, but I know bryan would like to be able to point people to various subsets of add-ons in post 3.0 releases)
Flags: blocking-thunderbird3+
(Reporter)

Updated

9 years ago
Blocks: 516884
I don't really agree with this at all. As long as you use the same URLs that Firefox uses (with s/firefox/thunderbird/), you should be fine. The URLs on Firefox aren't going to change without Thunderbird also being informed, and backwards-compatibility will always be kept for as long as a product line is supported (though probably longer). You're just forcing your users through yet another redirect that could possibly cause problems were live.momo.com to ever go down.
(Reporter)

Comment 2

9 years ago
How do I find out what URLs firefox uses?
(Reporter)

Comment 4

9 years ago
AFAICT from that file, Firefox currently doesn't offer links that are AMO search on the website itself, only on the services.addons.mozilla.com.  So it would be reasonable for AMO team not to see URLs like https://addons.mozilla.org/en-US/thunderbird/search?q=header as a guaranteed stable API at this point.

(If live.mozillamessaging.com goes down, we have bigger problems than breaking the add-ons searching experience.)

Would love input from philor (who first brought up the point in https://bugzilla.mozilla.org/show_bug.cgi?id=516884#c18) and gozer.
(In reply to comment #4)
> AFAICT from that file, Firefox currently doesn't offer links that are AMO
> search on the website itself, only on the services.addons.mozilla.com.  So it
> would be reasonable for AMO team not to see URLs like
> https://addons.mozilla.org/en-US/thunderbird/search?q=header as a guaranteed
> stable API at this point.

clouserw might can comment on this, but the search URIs haven't really changed from what I've seen over the years. There's some old rewrite rules you might can take advantage of, too (or add your own). Is there a specific category for such add-on types? Could just link directly to the category (which we have done in the past for Firefox when things have moved around).
(In reply to comment #4)
> Would love input from philor

And you'd get it, if you people would stop midairing me.

It's not "Firefox" it's "Toolkit" - we both use extensions.getAddons.search.browseURL, https://%LOCALE%.add-ons.mozilla.com/%LOCALE%/%APP%/search?q=%TERMS%, for the link to "see all" in the Get Add-ons pane.

In Firefox, that takes you to a page with all the matches, with the ones that won't work for you having a disabled button saying "for older versions". For Thunderbird, it takes you to a page with all the matches, with the ones that won't work for you looking exactly like the ones that will work for you.

I don't know why that API, the only stable API for HTML that I'm aware of, doesn't pass a version, since even for Firefox it seems like you might want to either only see things that work, or have the things that work listed first, but it does not. If someone has plenty of time on their hands, and wants to arrange with AMO to have a stable API for an HTML URI that includes passing in a version to only show, or to sort first, that'd be lovely, but given the amount of time we have to spare right now, balanced against the risk of having a link in a "Migration Assistant" firstrun page not work for a little while (a while during which the startpage will be broken, and autoconfig of new email accounts will be pretty bent though not quite broken), meh.

Updated

9 years ago
Whiteboard: [no l10n impact]
(Assignee)

Comment 7

9 years ago
(In reply to comment #1)
> I don't really agree with this at all. As long as you use the same URLs that
> Firefox uses (with s/firefox/thunderbird/), you should be fine.

Until there is a change that is important/wanted for Firefox that changes how things work for Thunderbird.

> The URLs on
> Firefox aren't going to change without Thunderbird also being informed, and
> backwards-compatibility will always be kept for as long as a product line is
> supported (though probably longer). You're just forcing your users through yet
> another redirect that could possibly cause problems were live.momo.com to ever
> go down.

live.momo.com is the highest priority, most highly-available website we have, and it's sole purpose, by design, is to be where *all* in-product Thunderbird URL point to (with aus the only exception I can think of), giving us the freedom to change anything we want, in any way we want, without having to change anything on the client-side.

Having Thunderbird search via a live.momo.com redirect is what I'd recommend, so I agree with david's suggestion.
(Assignee)

Comment 8

9 years ago
(In reply to comment #0)
> In bug 516884, we will introduce UI that wants to point people to a specific
> search on AMO.  In order to be robust w.r.t. any possible changes in AMO's HTTP
> API, domain, etc., we want to have a URL on a momo website which takes a URL w/
> query parameters from Thunderbird, and redirects the user to an appropriate
> page.
> 
> Proposal:
> 
> Thunderbird will point to something like:
> 
> https://live.mozillamessaging.com/thunderbird/addons?search=header&version=3.0&locale=en-US
> 
> which would redirect to:
>  
> https://addons.mozilla.org/en-US/thunderbird/search?q=header&appid=18hver=3.0&lver=3.0
> 
> obviously "en-US", "header", and "3.0" might vary.
> 
> I'm not sure whether we will ever want thunderbird to specify different values
> for hver and lver.  I kinda think not.

I'd suggest that like the start page, we make sure thunderbird sends along to that URL as much about itself as it known. os, version, etc, and we can just ignore it all initially when we are redirecting. In case we ever need some special-casing, it becomes really easy.
(Assignee)

Comment 9

9 years ago
<https?://live.mozillamessaging.com/thunderbird/addons/search?locale=en-US&q=header&lver=3.0&hver=3.0>

Is up and running now. All other arguments are ignored and not passed along.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Websites → www.mozilla.org

Updated

3 months ago
Product: www.mozilla.org → www.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.