pushloghtml is unreliable

VERIFIED FIXED

Status

mozilla.org Graveyard
Server Operations
--
major
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: sgautherie, Assigned: aravind)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
I have noticed that pushlog can:

* Take a moment to acknowledge new pushes.
While I felt like it always was immediate "before". (Though maybe I just didn't notice.)
(Noticed this for some time now.)

* Lastest pushes can be displayed then forgotten then redisplayed again...
This is even more painful on http://tests.themasta.com/tinderboxpushlog/
where builds move from one push to another :-(
(Noticed this recently only.)
I've also seen this a lot lately when I've been landing patches on multiple Hg repos. It's very frustrating, and it greatly confuses tbpl.
(Reporter)

Comment 2

9 years ago
Pike and ted told me to check:
http://dm-hg01.mozilla.org/mozilla-central/pushloghtml?startdate=1+day+ago&enddate=now
and
http://dm-hg02.mozilla.org/mozilla-central/pushloghtml?startdate=1+day+ago&enddate=now
which are behind
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=1+day+ago&enddate=now

Results of reloading both pages:
Both dm-hg0? "randomly" include/miss (my) lastest checkin.

Seems like the issue is at a "lower" level.
(Some stuck http/database connection/cache?)
(Assignee)

Updated

9 years ago
Assignee: server-ops → aravind
(Reporter)

Comment 3

9 years ago
Fwiw, comm-central push log has this bug too.
(Assignee)

Comment 4

9 years ago
I am unable to reproduce this issue.  Can I get a reproducible test case?  I have an idea on what could be going on, but I'd like to have a reproducible test case that I can use.
(Assignee)

Comment 6

9 years ago
Found that one of the backend webheads had the wrong timestamp on it.  Enabled time-sync options in vmware, so it should be good now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

9 years ago
Can't reproduce anymore atm, let's V.Fixed it.
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.