If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Notification of forgotten attachment should open a file manager window to browse for it

RESOLVED DUPLICATE of bug 516957

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED DUPLICATE of bug 516957
8 years ago
8 years ago

People

(Reporter: Andrea, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

It seems to me that TB3 beta4 introduces the recognition of words like "attach", "attachment" etc. to remember to the user a file has to be attached to the mail message he's composing.
I've noticed an inconsistent behaviour between the first notification (popup bar at the bottom of the composing window) and the second one.
In the popup bar, if you choose to attach a file immediately, you get a window to browse the contents of your computer and select the desired file.
In the alert dialog that appears after the send email command, if you answer "yes" (I've forgotten to attach a file), no browsing window is opened, though you're given the opportunity to attach files manually since the mail isn't sent.

My suggestion is to let Thunderbird open the browsing window in both cases, i.e. when you immediately accept TB's suggestion that appears in the popup bar, but also when you get the dialog window just before the message is sent.

Reproducible: Didn't try
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 516957
You need to log in before you can comment on or make changes to this bug.