Closed Bug 518863 Opened 10 years ago Closed 10 years ago

Thunderbird deletes session.json on exit if remove Global Search field from toolbar

Categories

(Thunderbird :: Search, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mozilla, Assigned: davida)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: TB 3.0 beta 4 / Lightning 1.0pre 2009-09-24 / WinXP

Thunderbird deletes session.json on exit if I remove the Global Search field from the toolbar.

Reproducible: Always

Steps to Reproduce:
1. Remove the Global Search field
2. Open more than one tab
3. Restart TB

Actual Results:  
Only the first tab appears.

Expected Results:  
All tabs that were open before the restart should appear.

I've also disabled "Tools > Options > Advanced > Global Search and Indexer".

I also use Lightning.  Normally I have Month View in tab #2 and no other tabs open.  However, I can reproduce it with only having mail tabs open when I restart.

Nothing in the error console, but the problem happens on exit so I don't know if any errors are thrown.
Duplicate of this bug: 518820
Pete is that issue also present if you launch TB in safe-mode ?
Flags: wanted-thunderbird3?
> Pete is that issue also present if you launch TB in safe-mode ?
Well, no, but the Global Search is always enabled on the toolbar when I launch TB in safe mode, even if I remove it before a restart.
Also, if I start TB in normal mode, disable all my extensions, remove Global Search from the toolbar, restart TB, open a message in tab 2, click on tab 1, click on Inbox, close TB, TB crashes.
(In reply to comment #4)
> Also, if I start TB in normal mode, disable all my extensions, remove Global
> Search from the toolbar, restart TB, open a message in tab 2, click on tab 1,
> click on Inbox, close TB, TB crashes.

Can you give is a crash ID for this ?
Attached patch one fixSplinter Review
The attached fix deals with an exception during the process of removing the search widget from the toolbar, but doesn't deal w/ the real issue.  Still, should get it in.
Attachment #403634 - Flags: review?(bienvenu)
Attached patch patch v1Splinter Review
This is the real fix (but the first patch is still valid).
Assignee: nobody → david.ascher
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #403647 - Flags: review?(bienvenu)
Attachment #403634 - Flags: review?(bienvenu) → review+
Comment on attachment 403647 [details] [diff] [review]
patch v1

together, these two patches make shutdown much happier. I'll land them.
Attachment #403647 - Flags: review?(bienvenu) → review+
fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Ludovic, I'd like to test this but I'm confused about which nightly I should download:

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/

latest-comm-1.9.1-l10n
latest-comm-1.9.1
latest-comm-central-l10n
latest-comm-central-trunk

I live in the U.S.
> latest-comm-1.9.1
is the one you want. If it works - please mark the bug verified.
This is fixed on my pc.  Thanks for your assistance.
Status: RESOLVED → VERIFIED
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.