Flash of the welcome page when first opening a message

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
9 years ago
a year ago

People

(Reporter: james, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [duptome])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

If no tabs are open in Thunderbird and I open a message then I get a quick flash of the welcome screen which is immediately replaced with the message text.

As a test, I changed my 'View'->'Message Body As'->'Plain text' to 'Original HTML'
now the flash up page is the last viewed html message I looked at.

Looks like a cache is failing somewhere and not being marked as invalid.

Reproducible: Always

Steps to Reproduce:
1. Close all tabs
2. Open a message
Actual Results:  
Flash of last HTML formatted page.  Normally the Welcome screen

Expected Results:  
No flash of page, just the message
Confirmed here on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091006 Lightning/1.0pre Shredder/3.0pre ID:20091006032243

but I think it is deliberate: I suppose that is how say "wait loading of message in progress"... otherwise you should see a blank page.

I think that this message should be closed as invalid.
(Reporter)

Comment 2

9 years ago
You should never see a flash of an image which you never get a chance to fully read.

Like I mentioned in the report you get a flash of the last message which was rendered in HTML format.  What happens if the message is of personal nature and the next time you read an email another party is watching?

This is most defiantly a bug and will force me back to version 2 if not properly addressed.
This should be fixed by bug 520272.
Status: UNCONFIRMED → NEW
Depends on: 520272
Ever confirmed: true
Duplicate of this bug: 535190
Whiteboard: [duptome]
Duplicate of this bug: 541711

Comment 6

9 years ago
Aureliano, et al: I see you marked my Bug no. 541711 as a duplicate of this one. However, my issue had nothing to do with a flash of the welcome screen. Only that when I open an email, the one previously opened comes up on the screen of a brief time. 

Is it the same? I'm not sure based on the description here. 

best, david
Hi David.
Underlying problem is the same.

Comment 8

9 years ago
And will it be fixed?

Comment 9

9 years ago
Is this a duplicate of bug 505446?
(In reply to comment #9)
> Is this a duplicate of bug 505446?

Probably very similar
Depends on: 505446
Duplicate of this bug: 589772
Duplicate of this bug: 593082

Updated

8 years ago
Severity: normal → minor

Updated

6 years ago
Duplicate of this bug: 669543

Comment 14

a year ago
almost certainly fixed in Bug 787475.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.