Ask a question form's final, required fields are out of the viewport's view

VERIFIED FIXED in 1.4.1

Status

support.mozilla.org
Forum
P2
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: stephend, Assigned: paulc)

Tracking

unspecified
1.4.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only, URL)

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
Created attachment 402882 [details]
Screenshot

STR:

1. Reduce your viewport to be about half the height of a typical 1024x768 (etc.) screen, so around 580 pixels
2. Load http://support-stage.mozilla.org/en-US/kb/Support+Website+Forums
3. Click on "Ask a new question"
4. Advance through the screens until "Ask a question step 4 of 4"
5. Type something in the "Fill in the details of your question" text box and click "Submit your question"

Even though there is a scrollbar, it's not clear there's a lot of other required fields.

Comment 1

8 years ago
1) Lots of netbooks have only 600 px vertical height so it's not an uncommon usecase.

2) The issue is that the submit button is still there and active so it looks like you're seeing the entirety of the form when you're not.  The previous screens of the dialog scroll inside the browser (and people with short screens expect to have to scroll) but this one has its own scrollbar which is confusing.
(Assignee)

Comment 2

8 years ago
So you're saying let's just let the modal window expand height instead of making it fit inside but adding a scrollbar inside it?
Assignee: nobody → paulc
(In reply to comment #2)
> So you're saying let's just let the modal window expand height instead of
> making it fit inside but adding a scrollbar inside it?

+1. That's what I'd recommend.
(Assignee)

Comment 4

8 years ago
1.4.1 ok?
Target Milestone: --- → 1.4.1

Comment 5

8 years ago
Yeah, 1.4.1 is going to be epic.

Comment 6

8 years ago
Affects roughly 2.9% of our visitors (based on total page hits, not traffic to the forum).

Not sure if related, but I also noticed that the box appears too far to the left if screen size is narrow, e.g. 640x480 -- the box is then not centered on the screen. Not a big deal though (affects roughly 0.2% of visitors).
Priority: -- → P2
(Assignee)

Comment 7

8 years ago
Created attachment 403975 [details] [diff] [review]
v1

No "max-height" does the trick.
Attachment #403975 - Flags: review?(james)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 519643
Attachment #403975 - Flags: review?(james) → review+
(Assignee)

Comment 9

8 years ago
r52769 (trunk only)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

8 years ago
Created attachment 404356 [details]
Post-fix screenshot on Ubuntu 9.04

Cheng, does this look good to you?  Can you confirm with your setup too?  Thanks!

Comment 11

8 years ago
It looks good as far as addressing the bug but for some reason when you click next from step 3, it takes you to the middle of the form rather being scrolled up to the top.  That's not a big deal, just weird.
(Reporter)

Comment 12

8 years ago
(In reply to comment #11)
> It looks good as far as addressing the bug but for some reason when you click
> next from step 3, it takes you to the middle of the form rather being scrolled
> up to the top.  That's not a big deal, just weird.

thx, Cheng -- sounds like a spinoff candidate.

Verified FIXED
Status: RESOLVED → VERIFIED
(Assignee)

Comment 13

8 years ago
r53560 (prod)
Whiteboard: sumo_only
You need to log in before you can comment on or make changes to this bug.