Closed Bug 518928 Opened 11 years ago Closed 10 years ago

nanojit: #define STRESS_REGALLOC

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 529430

People

(Reporter: njn, Assigned: njn)

Details

A useful way to stress the register allocator is to reduce the number of registers available to the minimum.  Eg. on x86 I think this is eax/edx/ecx.  But it requires modifying a couple of places.  So it would be good to have a #define that can be set to turn this stress mode on, and define it for each backend.
As part of this, we could have a static assert that ensures that the minimal set of registers is available.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 529430
You need to log in before you can comment on or make changes to this bug.