Windows Leak builds busted from Tracemonkey merge on Fri Sep 25 20:38:06 2009 -0700

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
blocker
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: standard8, Assigned: Robert Sayre)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
The landing of the tracemonkey merge:

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2009-09-25+20%3A38&enddate=2009-09-25+20%3A38%3A10

has caused the Windows leak & bloat builds to be busted on both Firefox and Thunderbird trunk trees.

I couldn't find anyone monitoring this to raise on irc so filing bug instead. I also didn't want to back out due to the large number of changesets. Filing as blocker as in theory no-one else can check in until this is fixed.

Example log:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1253953601.1253957784.28648.gz

++DOCSHELL 060DEF20 == 5
WARNING: NS_ENSURE_TRUE(browserChrome) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/docshell/base/nsDocShell.cpp, line 9879
WARNING: Something wrong when creating the docshell for a frameloader!: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsFrameLoader.cpp, line 912
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsFrameLoader.cpp, line 936
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsFrameLoader.cpp, line 193
pldhash: for the table at address 061B8EB8, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 061B8E50 == 6
++DOMWINDOW == 7 (061CE5C0) [serial = 7] [outer = 00000000]

command timed out: 1200 seconds without output
program finished with exit code 1
elapsedTime=1268.250000
(Assignee)

Comment 1

9 years ago
I believe this was caused by

Brendan Eich — High-level CSE for shape guards (518448, r=jorendorff).

which I (and others) should have seen on the TM tree, since it happens there as well.
(Assignee)

Updated

9 years ago
Assignee: general → sayrer
(Assignee)

Comment 2

9 years ago
backed out everywhere, see bug 518448 for follow-ups.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.