Last read message is not automatically marked as read

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
10 years ago
9 years ago

People

(Reporter: dev, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-09-15], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.21 Safari/532.0
Build Identifier: Thunderbird 3.0b4

Say I receive three e-mails. I can view the first two in the three-pane message viewing area and the "new message" indicator (the "emboldened" data for the message in the top right pane, the global smart folder message list) is turned off indicating that the message is read. The last message, no matter how long I view it for also stays emboldened despite having been read. When a new e-mail comes in, it _still_ stays emboldened along with the single new e-mail (see linked screenshot).

This only happens using the new smart folders.

Reproducible: Always

Steps to Reproduce:
1. Using the new smart folders feature, send yourself three e-mails 
2. Note that the first two you look at are visually indicated (de-emboldened) as being read
3. The last message is not changed to being marked as read (stays bold).
Actual Results:  
Nothing unexpected, just a visual fault.

Expected Results:  
The messages should be visually indicated as being marked read.

Comment 1

9 years ago
I've encountered the same problem.  You have to manually mark the message as read to get the bold highlight to go away (annoying!).
Ryan, webolutionary, do you still see this in version 3.1?
Whiteboard: [closeme 2010-09-15]
Version: unspecified → 3.0
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.