Clicking search results gives a blank tab

RESOLVED WORKSFORME

Status

Thunderbird
Search
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: slyfoxlp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [workaround comment #18])

Attachments

(1 attachment, 1 obsolete attachment)

65.14 KB, image/jpeg
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

When performing certain searches searches, the result window has the results I am looking for, but when clicking the actual result it takes me to a blank tab (blank top section and "welcome to thunderbird" bottom section.

I attempted to work around the problem by selecting "show all as list" option instead, but all the results I want (from a certain email account) are not present. Other search results work as expected, even for that email account.

It might be a bad search index, but I attempted to rebuilt it to no avail.  I can take screen shot to provide an example, if you provide me a place to upload the images.

This bug happens every time with certain searches (where I guess the index is bad).

Reproducible: Sometimes

Steps to Reproduce:
1.Perform a search in the search bar
2.click a result
3.
Actual Results:  
a blank tab opens in thunderbird.

Expected Results:  
the desired result will be displayed in a new tab.
(Reporter)

Comment 1

8 years ago
Created attachment 403076 [details]
pdf showing images of the issue
I can confirm also here but I don't have a closely STR (it seems to happens when a message result is starred for example).

No message in error console.
(In reply to comment #2)
> I can confirm also here but I don't have a closely STR (it seems to happens
> when a message result is starred for example).

Can you try to figure out proper STRs ?
I have my mozilla folder threaded sort by date (descending).

I see that when I have a search result that is related to a thread with > 1 message, clicking on search result TB work fine. If I have a search result that is related to a thread with = 1 only message, clicking on search result TB display a blank tab.

I'm not sure that this is right behaviour.
I have this type of errors in my error console:

Error: this.row.words is undefined
Source File: chrome://gloda/content/glodacomplete.xml
Line: 434

Warning: anonymous function does not always return a value
Source File: chrome://messenger/content/jquery.js
Line: 12, Column: 125
Source Code:
ction(){var H=this;while(H&&H.ownerDocument){if(G?G.index(H)>-1:o(H).is(E)){o.data(H,"closest",F);return H}H=H.parentNode;F++}})},not:function(E){if(typeof E==="string"){if(f.test(E)){return this.pushStack(o.multiFilter(E,this,true),"not",E)}else{E=o.mult

Warning: anonymous function does not always return a value
Source File: chrome://messenger/content/jquery.js
Line: 12, Column: 105
Source Code:
ame(O,"tr")?(N.getElementsByTagName("tbody")[0]||N.appendChild(N.ownerDocument.createElement("tbody"))):N}}};o.fn.init.prototype=o.fn;function z(E,F){if(F.src){o.ajax({url:F.src,async:false,dataType:"script"})}else{o.globalEval(F.text||F.textContent||F.in

Warning: anonymous function does not always return a value
Source File: chrome://messenger/content/jquery.js
Line: 19, Column: 8
Source Code:
T?[T]:[]}},NAME:function(V,Y,Z){if(typeof Y.getElementsByName!=="undefined"){var U=[],X=Y.getElementsByName(V[1]);for(var W=0,T=X.length;W<T;W++){if(X[W].getAttribute("name")===V[1]){U.push(X[W])}}return U.length===0?null:U}},TAG:function(T,U){return U.ge

Warning: anonymous function does not always return a value
Source File: chrome://messenger/content/jquery.js
Line: 19, Column: 223
Source Code:
T?[T]:[]}},NAME:function(V,Y,Z){if(typeof Y.getElementsByName!=="undefined"){var U=[],X=Y.getElementsByName(V[1]);for(var W=0,T=X.length;W<T;W++){if(X[W].getAttribute("name")===V[1]){U.push(X[W])}}return U.length===0?null:U}},TAG:function(T,U){return U.ge

Warning: variable W redeclares argument
Source File: chrome://messenger/content/jquery.js
Line: 19, Column: 207
Source Code:
U}},filter:{PSEUDO:function(Z,V,W,aa){var U=V[1],X=I.filters[U];if(X){return X(Z,W,V,aa)}else{if(U==="contains"){return(Z.textContent||Z.innerText||"").indexOf(V[3])>=0}else{if(U==="not"){var Y=V[3];for(var W=0,T=Y.length;W<T;W++){if(Y[W]===Z){return fals

Warning: anonymous function does not always return a value
Source File: chrome://messenger/content/jquery.js
Line: 19, Column: 16
Source Code:
e}}return true}}}},CHILD:function(T,W){var Z=W[1],U=T;switch(Z){case"only":case"first":while(U=U.previousSibling){if(U.nodeType===1){return false}}if(Z=="first"){return true}U=T;case"last":while(U=U.nextSibling){if(U.nodeType===1){return false}}return tru

Warning: test for equality (==) mistyped as assignment (=)?
Source File: chrome://messenger/content/jquery.js
Line: 19, Column: 210
Source Code:
e}}return true}}}},CHILD:function(T,W){var Z=W[1],U=T;switch(Z){case"only":case"first":while(U=U.previousSibling){if(U.nodeType===1){return false}}if(Z=="first"){return true}U=T;case"last":while(U=U.nextSibling){if(U.nodeType===1){return false}}return tru
(In reply to comment #4)
> I see that when I have a search result that is related to a thread with > 1
> message, clicking on search result TB work fine. If I have a search result that
> is related to a thread with = 1 only message, clicking on search result TB
> display a blank tab.
> 
> I'm not sure that this is right behaviour.

WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090927 Lightning/1.0pre Shredder/3.0pre
Try with:

1. in your mozilla folder select 2 threads (for example I have select thread 1 "[Bug 510531] BCC is DISCLOSING recipients" and thread 2. "Clicking search results gives a blank tab" and move all messages in a new folder on Local folders.
2. search with global search words "Clicking search": in tab search results I have 2 items: click one of this produce a blank tab detail.

Anyone can confirm?
ps: in step 1 in new folder I have set sort threaded sort by date (descending)
Created attachment 403220 [details]
screenshot

a screenshot of the issue
Attachment #403076 - Attachment is obsolete: true
(Reporter)

Comment 10

8 years ago
I have the same issue when doing the clicking search, and the issue occurs even for messages sorted by from.  Although, it only occurs when clicking some messages, other messages correctly display an email (but the top section above the email has way too few results) when it does display something.
Another error console message:

2009-09-28 20:14:03	gloda.indexer	WARN	Problem during [job:folder delta:0 id:15 items:0 offset:2 goal:43], trying to recover.  Problem was at undefined:2654: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgFolder.GetMessageHeader]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///C:/Programmi/Mozilla%20Thunderbird/modules/gloda/indexer.js :: gloda_indexMessage :: line 2654"  data: no]
(Reporter)

Comment 12

8 years ago
here is an error console message on search:

Error: [Exception... "'JavaScript component does not have a method named: "observe"' when calling method: [nsIObserver::observe]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: onKeyPress :: line 424"  data: no]
Source File: chrome://global/content/bindings/autocomplete.xml
Line: 424
New attempt (STR?)

1. Go to folder that is sort by date (descending) and threaded (has importance?
I don't think);

2. select an email with long title and no special character. In my mozilla
thunderbird bugs folder I have select thread that has title "[Bug 492692]
Cannot display Chinese email in UTF-8 by default"

3. copy title in step 2 in global search with "search all messages" option and
after paste long title choice option "messages with ALL of:"

4. on tab search result click on first result: TB open a new tab detail that
show for < 1 sec tab in "message pane" but nothing in message list. 

5.After 1 second the situation it is that described for my attached screenshot
(message list remain blank and message pane show "Welcome to Shredder" page)


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090928 Lightning/1.0pre Shredder/3.0pre ID:20090928031704
Whiteboard: [STR in comment #13?]
(In reply to comment #13)

> 4. on tab search result click on first result: TB open a new tab detail that
> show for < 1 sec tab in "message pane" but nothing in message list. 


4. on tab search result click on first result: TB open a new tab detail that
show for < 1 sec in "message pane" the message clicked but nothing in message list.
(In reply to comment #13)
> New attempt (STR?)

This works for me with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090927 Shredder/3.0pre. Could this be windows only. Wayne could you give a shot a reproducing with Aureliano's STRs ?

Comment 16

8 years ago
can't reproduce
(Reporter)

Comment 17

8 years ago
What are the steps to force the search index to rebuild?  I want to try that to see if results change at all.

Thanks.
(In reply to comment #17)
> What are the steps to force the search index to rebuild?  I want to try that to
> see if results change at all.

remove the global-messages-db.sqlite file from your profile that should kick gloda back to indexing.
(In reply to comment #18)

> remove the global-messages-db.sqlite file from your profile that should kick
> gloda back to indexing.

Here it seems that this workaround solve this issue.

Thanks Ludo ;-D
Whiteboard: [STR in comment #13?] → [workaround comment #18]
Can someone save a bad db for analysis so asuth can have a look at what is causing the issue ?
(Reporter)

Comment 21

8 years ago
I saved mine, it's 105 mb.  How would you like me to give it to you?
(Reporter)

Comment 22

8 years ago
I can also confirm that rebuilding the index appears to fix everything, I have my original database for whoever needs it.

What's interesting to note is the bad index returns search snippets for everything, but could not display the results themselves or show them in list view (for certain searches).
(In reply to comment #22)
> I can also confirm that rebuilding the index appears to fix everything, I have
> my original database for whoever needs it.

Andrew will probably ask for that when he comes back from vacation next week.

Marking new because we potentially have a db and two different users.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 24

8 years ago
After archive several thousand emails and letting the index update I had the same issue come back.  I guess it didn't re-index correctly.  Manually deleting my index and letting it re-index overnight resolved the issue.
Also here... but I think that We must have patience until  :asuth come back.

ps: my db is 13 MB
Bugs in the gloda indexing mechanism allow it to get out-of-sync with the underlying messages.  This is likely resulting in a failure when trying to open the tab which causes incomplete setup of the tab.  This results in odd errors.

I will re-visit this bug once we have stamped out the known gloda problems in nightlies.

In general you do not want to send me or anyone your global-messages-db.sqlite.  It is likely to have all kinds of personal information in it.  In the future if the need arises we will construct extensions or code you can paste into the error console that will extract the required characteristics of your database without revealing personal information.  (Or limited information which is concise enough that you can examine it and verify that you are willing to have it revealed.  This would be required in cases where something specific in the data is causing problem, like someone's name including unexpected encodings or the like.)
Oh, right, and deleting your global-messages-db.sqlite works because it ensures that only up-to-date message information is in the file.  But since you still have all the same messages and gloda still has all the same bugs (for now), so it is likely to eventually end up with the same problem.

Avoiding compacting folders is likely to be the most useful thing you can do to avoid the problem.
(In reply to comment #27)

> Avoiding compacting folders is likely to be the most useful thing you can do to
> avoid the problem.

The issue is resurrect today: compacting folders not resolve anithing here :-(
(In reply to comment #27)
> Avoiding compacting folders is likely to be the most useful thing you can do to
> avoid the problem.

Aurelio, I understand from comment #27 that you should NOT compact your folders because that's going to cause problems right now (compacting isn't handled well by gloda).
(In reply to comment #29)
> Aurelio, I understand from comment #27 that you should NOT compact your folders
> because that's going to cause problems right now (compacting isn't handled well
> by gloda).
Yes is my mistake (I had not read "Avoiding" ;-) )
The gloda correctness fixes have landed on the trunk.  This should no longer occur.  Please re-open if you still experience this problem using today's comm-1.9.1 nightly or more recent.  The problem will still exist in beta 4.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.