[PP] url location control bar not working correctly on Linux

VERIFIED DUPLICATE of bug 5217

Status

P2
normal
VERIFIED DUPLICATE of bug 5217
20 years ago
14 years ago

People

(Reporter: cmaximus, Assigned: radha)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
As of this morning's Linux build, it is very diffucult to surf handtyped url's.

Build Linux 1999041608. WinNT and Mac check out OK

To repro*

Start linux apprunner. try to click in the URL bars, as if you were going to type a new url.
Try to drag select and delete the whole thing and type a new one or try to set the cursor at the end of the url and delete it.
If it works once, I bet it won't work twice.

expected*
all of these should function normally and you should be able to type a new url, hit enter and go there.

actual results*
	Sometimes you can type and get ot go to your page. More often than not clicking in the url bar triggers 'going forward' and
or a reload. Often, you just can't access the url bar. repeated action has yielded a crash on my machine.
(Reporter)

Updated

20 years ago
QA Contact: 3849 → 4130

Updated

20 years ago
Assignee: don → radha
Priority: P3 → P2
Target Milestone: M5

Comment 1

20 years ago
Re-assigned to radha.
I have seen this.  The deal used to be,

Clicking on the first half of the urlbar used to activate one of the button to
the left of the urlbar. For example, clicking at leftmost position of urlbar
used to activate back button. Click few pixels to the right, forward button used
to activate. If you click in the later half of the urlbar, you would get control
of the urlbar and can type  in. It looks like a layout problem to me. I'm not
sure if this is due to the introduction of the <box> element.

ccing ramiro, evaughan, don
(Reporter)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

20 years ago
aha.. if that is truly the case then this is really a dupe of bug 5217. I should read my own writing. Something did change with this
build however. for 5217 there was always the extraneous mouseover action but it didn't trigger the buttons. Now, you get the
mouseover AND the button action.


*** This bug has been marked as a duplicate of 5217 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Verified Dup of Bug 5217
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.