"Sign In" is greyed out in Weave menu when Firefox starts, in Weave 0.7pre4

VERIFIED FIXED in 0.8

Status

Cloud Services
Firefox Sync: UI
P2
critical
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: dholbert, Assigned: Mardak)

Tracking

({regression})

unspecified
x86
Linux
regression
Points:
---
Bug Flags:
blocking-weave1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
STEPS TO REPRODUCE:
 1. Install Weave 0.7pre4 in a fresh Firefox profile, & restart Firefox
 2. Enter your existing Weave login credentials on the Weave firstrun page, and click through the rest of the firstrun process, accepting all the defaults.
 3. Restart Firefox (once you're done with the firstrun stuff)
 4. Click the Weave context menu.  Or, open the Tools menu, and look at the Weave submenu.

ACTUAL RESULTS: "Sign In" is greyed out.
EXPECTED RESULTS: "Sign In" should be available.

NOTE: I can still sign in by manually visiting the "about:weave" URL.

NOTE: I initially hit this bug just now when upgrading from Weave 0.7pre3 to 0.7pre4.  As suggested by the STR above, I've confirmed that it also happens in a fresh profile + weave 0.7pre4 with weave credentials entered.
(Reporter)

Updated

9 years ago
Severity: normal → critical
(Reporter)

Updated

9 years ago
Summary: "Sign In" is grayed out in Weave status-bar menu, in Weave 0.7pre4 → "Sign In" is greyed out in Weave menu when Firefox starts, in Weave 0.7pre4
(Assignee)

Comment 1

9 years ago
Can you check if the Sign In item stays grayed out after a minute or so? Weave might not be initialized yet, but we should probably show something in the UI relating to that then..
(Reporter)

Comment 2

9 years ago
I've had firefox running for almost an hour, and the Sig nIn item is still grayed out.
(Reporter)

Comment 3

9 years ago
I just upgraded to Weave 0.7, and this is still broken in that version.

Browser: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20090930 Minefield/3.7a1pre
(Assignee)

Comment 4

9 years ago
Hrm, there's 3 ways to make the sign in menu item disabled.. could you try this in the Error Console?

Components.utils.import("resource://weave/service.js"); [Weave.Svc.IO.offline, Weave.Service.status.service == Weave.STATUS_DELAYED, Weave.Service.locked]

That should result in false,false,false when Sign In is made clickable.
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> Components.utils.import("resource://weave/service.js"); [Weave.Svc.IO.offline,
> Weave.Service.status.service == Weave.STATUS_DELAYED, Weave.Service.locked]

When I start Firefox (and "sign in" is grayed out), that command returns:
 false,true,

If I manually visit about:weave and sign in, then the command returns:
 false,false,false
(Assignee)

Comment 6

9 years ago
And how about if you restart firefox without about:weave in session restore and wait a minute?
(Reporter)

Comment 7

9 years ago
...then nothing happens.  BUT I figured it out -- it's because I have "Keep me signed into weave" *unchecked* in about:weave.

If I _check_ that box (and then log in & out of weave[1]) and then restart Firefox, **THEN** Weave will attempt to automatically log in in the background after a few seconds.

Since I have a master password, this background login triggers an unexpected Master Password dialog.  If I enter my password, then weave logs me in, and everything's fine.  But if I dismiss the dialog, I'm stuck with this bug.

[1] AFAICT, changes to the "keep me signed into Weave" checkbox don't take effect unless I sign into weave after toggling the box.
(Reporter)

Comment 8

9 years ago
I've tested this in a fresh profile, both with & without a master password.

As far as I can tell, the "first minute" Weave initialization consists of:
 - If auto-login ("keep me signed into weave") is disabled, do nothing.  Sign In stays grayed out -- BAD!
 - If auto-login is enabled, then:
   -- If profile has no master password, log in -- GOOD.
   -- If profile has a master password, prompt for the master password.
     --- If user dismisses dialog, give up. Sign in stays grayed out -- BAD!
     --- If user enters correct master password, sign in. -- GOOD.
     --- (if user enters incorrect master password, keep prompting until they get it right or dismiss the dialog)
(Assignee)

Comment 9

9 years ago
mconnor: we probably just need to reset the service status to not be delayed before doing autoconnect. Otherwise, service status stays DELAYED until login.. which is disabled from the menu.
(Reporter)

Updated

9 years ago
Flags: blocking-weave1.0?
(Reporter)

Comment 10

9 years ago
(In reply to comment #7)
> [1] AFAICT, changes to the "keep me signed into Weave" checkbox don't take
> effect unless I sign into weave after toggling the box.

(FWIW, I just filed bug 520039 on this separate issue)
(Assignee)

Updated

9 years ago
Assignee: nobody → edilee
Flags: blocking-weave1.0? → blocking-weave1.0+
Target Milestone: --- → 0.8
(Assignee)

Comment 11

9 years ago
http://hg.mozilla.org/labs/weave/rev/9ba199fa5574
Switch back to STATUS_OK (from STATUS_DELAYED) when the delayed startup is actually called.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Priority: -- → P2
(Reporter)

Comment 12

9 years ago
Verified fixed in Weave 0.8pre1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.