Deleting a collapsed thread fails to delete the entire thread - only the first message

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: gjunk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.3) Gecko/20090909 Fedora/3.5.3-1.fc11 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.4pre) Gecko/20090926 Shredder/3.0pre ID:20090926030509

Collapse a thread - choose to delete (or shift delete) - only the first message is deleted instead of the entire thread.

Thereafter an empty line appears at the top of the message list - which is not clickable.

Clicking out of mail folder and back the blank line goes away.



Reproducible: Always




This used to work fine in earlier versions than 3.0pre - at least it worked with beta 3 and I was pretty sure it worked fine in beta4 as of early september.
Gene can you try to find when this regressed ? 

do you have the issue when using Thunderbird in safe-mode ?

This WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090927 Shredder/3.0pre
Keywords: regression, regressionwindow-wanted
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 2

9 years ago
Ok  - i tried this on 2 systems using same 386 executable version as above

  a) 386 machine fedora 10 - problem was there.
     safe mode - problem went away
     return to normal mode - problem stayed away

  
  b) x86_64 on fedora 11

      problem is there in safe mode as well - and there are errors printed.


Observation - when it fails, the display only shows the first message of the thread and NOT the list summarizing all the thread messages.

From the below trace, the first error is GLODA - (this is still on) I wonder i fI should remove the zillion gigabyte file and wait the long long time for it to be recreated ?


sample of first few Errors received from (b) 

-- Exception object --
+ message (string) 'nounDef is undefined'
+ fileName (string) 'file:///opt/Local/vers/mozilla/released/thunderbird-3.0pre-090927/modules/gloda/gloda.js'
+ lineNumber (number) 1800
+ stack (string) 552 chars
+ name (string) 'TypeError'
*
-- Stack Trace --
<top>
nsAutoCompleteGloda@file:///opt/Local/vers/mozilla/released/thunderbird-3.0pre-090927/components/glautocomp.js:480
anonymous@file:///opt/Local/vers/mozilla/released/thunderbird-3.0pre-090927/modules/XPCOMUtils.jsm:245
[anonymous]@null:0
[anonymous]@chrome://messenger/content/search.xml:211
-- Exception object --
+ message (string) 'nounDef is undefined'
+ fileName (string) 'file:///opt/Local/vers/mozilla/released/thunderbird-3.0pre-090927/modules/gloda/gloda.js'
+ lineNumber (number) 1800
+ stack (string) 1003 chars
+ name (string) 'TypeError'
*
-- Stack Trace --
<top>
summarizeThread@chrome://messenger/content/selectionsummaries.js:630
MessageDisplayWidget_showSummary@chrome://messenger/content/messageDisplay.js:314
MessageDisplayWidget_onSelectedMessagesChanged@chrome://messenger/content/messageDisplay.js:225
FolderDisplayWidget_summarizeSelection@chrome://messenger/content/folderDisplay.js:1216
[anonymous]@null:0
ThreadPaneSelectionChanged@chrome://messenger/content/threadPane.js:324
onselect@chrome://messenger/content/messenger.xul:1
[anonymous]@null:0
onxblmousedown@chrome://global/content/bindings/tree.xml:975
-- Exception object --
+ message (string) 'nounDef is undefined'
+ fileName (string) 'file:///opt/Local/vers/mozilla/released/thunderbird-3.0pre-090927/modules/gloda/gloda.js'
+ lineNumber (number) 1800
+ stack (string) 1917 chars
+ name (string) 'TypeError'
*
-- Stack Trace --
<top>
summarizeThread@chrome://messenger/content/selectionsummaries.js:630
MessageDisplayWidget_showSummary@chrome://messenger/content/messageDisplay.js:314
MessageDisplayWidget_onSelectedMessagesChanged@chrome://messenger/content/messageDisplay.js:225
FolderDisplayWidget_summarizeSelection@chrome://messenger/content/folderDisplay.js:1216
[anonymous]@null:0
FolderDisplayWidget_selectViewIndex@chrome://messenger/content/folderDisplay.js:2029
FolderDisplayWidget_onMessagesRemoved@chrome://messenger/content/folderDisplay.js:1046
DBViewWrapper__deleteCompleted@file:///opt/Local/vers/mozilla/released/thunderbird-3.0pre-090927/modules/dbViewWrapper.js:1256
FolderNotificationHelper__notifyHelper@file:///opt/Local/vers/mozilla/released/thunderbird-3.0pre-090927/modules/dbViewWrapper.js:229
FolderNotificationHelper_OnItemEvent@file:///opt/Local/vers/mozilla/released/thunderbird-3.0pre-090927/modules/dbViewWrapper.js:268
[anonymous]@null:0
FolderDisplayWidget_doCommand@chrome://messenger/content/folderDisplay.js:1636
anonymous@chrome://messenger/content/mail3PaneWindowCommands.js:598
doCommand@chrome://messenger/content/tabmail.xml:1054
goDoCommand@chrome://global/content/globalOverlay.js:86
oncommand@chrome://messenger/content/messenger.xul:1
-- Exception object --
+ message (string) 'nounDef is undefined'
+ fileName (string) 'file:///opt/Local/vers/mozilla/released/thunderbird-3.0pre-090927/modules/gloda/gloda.js'
+ lineNumber (number) 1800
+ stack (string) 1003 chars
+ name (string) 'TypeError'
*
(Reporter)

Comment 3

9 years ago
Update

 1) deleting the global index stuff revives the appearance of collapsed threads and their deletability - tho why this has anything to do with searching is a bit strange.

  2) After 9 hours of the activity monitor saying checking inbox for messages to index - i had to to go to work and exit thunderbird

   which a) does not exit cleanly (i have to had kill the residual running processes)

         b) the size and last written timestamp of the global index is identical to 9 hours earlier. (yes 9 hours!!)


  Aside - Why anyone would ever want a global index spannign multiple accounts is utterly beyond me - within all folders in 1 account yes - and possibly the ability to search across those 4 or 5 accounts sequentially maybe with the user selecting which accounts to search - but this global index thing seems to be an enormously bad idea looking for a use. Please suggest indexing each account separately, it is a far better design.


thanks.

Updated

9 years ago
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
Version: unspecified → 3.0

Comment 4

9 years ago
I believe asuth fixed a bug related to the nounDef undefined error, so this is probably a dup of the gloda correctness bug. Though it would seem like the thread summary stuff should be somewhat resilient in the face of gloda exceptions.
(Reporter)

Comment 5

9 years ago
I have gloda turned off with 3.0.1pre and this is not an issue.
WFM per reporter. If this is incorrect, please update the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

8 years ago
As I said above turning off GLODA fixes the problem - 

I cannot say if its there or not with GLODA on - I'll leave that to others to confirm - but if you have it working and GLODA is on then its probably fixed - earlier versions of gloda were quite buggy so it is reasonable that those fixes may well have fixed it.

sorry the I really dont want to turn GLODA on - it has been nothing but problematic for me.

I'm happy to leave this resolved
You need to log in before you can comment on or make changes to this bug.