Closed Bug 519165 Opened 13 years ago Closed 13 years ago

Modifies text spaces upon reply in text only with < (minor sign) in body.

Categories

(Thunderbird :: Message Compose Window, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 448198

People

(Reporter: Mail2, Unassigned)

References

Details

(Keywords: regression, Whiteboard: dupeme?)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0b4

When I reply to an email using text only reply, and if the text in the body of this email contains a "<" (minor) sign, this minor sing (and the text following it) moves to the left up against the last letter before the < sing.
I tried reproducing it to my self but at first it didn't happen, but it always happened if the email was sent via web mail or sent by someone else maybe in an 8 bit format:
Content-Type: text/plain; charset=utf-8; Content-Transfer-Encoding: 8bit
or Content-Type: multipart/alternative;

Reproducible: Always

Steps to Reproduce:
1. Go to a webmail account and send yourself an email containing a text in the body with: some text     < (minor sign) or/and with          < and some other text and lots of spaces and then       <
2. in Thunderbird3.0b4 "Account settings" in the email account in "Composition & Addressing", uncheck "Compose messages in HTML format"
3. Then in TB go to inbox and reply the email you just sent yourself. 
Actual Results:  
> some text < (minor sign) or/and with < and some other text and lots of spaces and then <

There are no spaces before the < as the original email.

Expected Results:  
> some text     < (minor sign) or/and with          < and some other text and lots of spaces and then       <

There should be lots of spaces before the < as the original email.
This looks like a special case of bug 448198, in which however the removal of just one space before a '<' is reported. Thus, it may not be a duplicate but likely caused by bug 215068 as well.
Whiteboard: dupeme?
Depends on: 448198
Keywords: regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is definitely a dupe.  The test case I put up at bug 448198 simply hadn't included multiple spaces around the characters, but I just tried that same test data with multiple spaces and the multiple spaces collapse in the same way as the single ones did.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
No longer blocks: 215068
You need to log in before you can comment on or make changes to this bug.