[MAC] When tabbing through a form drop-down lists boxes are skipped (Mac Only)

RESOLVED DUPLICATE of bug 437296

Status

()

Core
Keyboard: Navigation
RESOLVED DUPLICATE of bug 437296
9 years ago
9 years ago

People

(Reporter: carlo.lazzerini+garbage, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

If you happen to be filling out a form and want to use the tab key to transition between form elements, tabbing skips the drop-down list boxes when they are present.  I created a basic form from scratch to test the problem and noticed that even when you select the drop-down list box, tab to the next form element, and attempt to shift+tab back to the list box, Firefox fails to go back to the drop-down list box.

Reproducible: Always

Steps to Reproduce:
1. Find a form with at least 1 drop-down list box and 1 text input field.
2. Give focus to one of the elements in the form.
3. Tab attempt to tab/shift+tab to the drop-down list box.
Actual Results:  
drop-down list box is always skipped

Expected Results:  
drop-down list box should be accessible via some combination of tab or shift+tab commands.

Sample code will be provide after the bug has been filed.
(Reporter)

Comment 1

9 years ago
Created attachment 403194 [details]
test case

It should be noted that although this form is not complete in that it does not have a submission element, this bug is present in every from I have filled out(including this one) since using Firefox on my new Mac.
I can confirm this on: 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2b1pre) Gecko/20090929 Namoroka/3.6b1pre (.NET CLR 3.5.30729)

In Safari, focus will go to the drop-down list.

The default keyboard setting "Full Keyboard Access" on Mac OS X is to "move keyboard focus between 'Text boxes and lists only'".  The select element should be included in that as it is a list (like it does in Safari).  

Changing the "Full Keyboard Access" setting (System Preferences > Keyboard > Keyboard Shortcuts)to 'All controls' is a workaround for this in the meantime.
Blocks: 335226
Component: General → Keyboard: Navigation
Product: Firefox → Core
QA Contact: general → keyboard.navigation

Comment 3

9 years ago
I can confirm this as well on Seamonkey for the Mac.  It's been like this for years, and it's always been a real pain.

Also, I don't see a "Full Keyboard Access" anywhere in the Keyboard system preferences.

Comment 4

9 years ago
Firefox respects what you have set in System Preferences. You'll need to change
the setting if you want this functionality.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437296
You need to log in before you can comment on or make changes to this bug.