Subject truncation for UTF-8 encoded email

RESOLVED DUPLICATE of bug 493544

Status

MailNews Core
MIME
RESOLVED DUPLICATE of bug 493544
9 years ago
9 years ago

People

(Reporter: Watergad, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2

Subject displays truncated for UTF-8 coded email.
If there's something like that in the subject:
=?utf-8?B?W9Ca0J/QoyAwMDAwMDAxXTog0JrQsNGB0YHQsCDQvdC1INC/0LXRh9Cw0YLQ?==?utf-8?B?sNC10YIg0YHQvNCw0LnQu9C40LrQuA==?= 
we see subject as only about 30 chars ended with "�" symbol. Same time outlook express shows whole subject as it was sent.

Reproducible: Always

Steps to Reproduce:
1. Just receive "bad" email
2. And see how it shows
Actual Results:  
Subject is truncated

Expected Results:  
Subject shows as it was sent
(Reporter)

Comment 1

9 years ago
Created attachment 403225 [details]
Truncated subject in the message list

Because I don't beleive in the power of my language skill, I'll attach this screenshot for more clearness.

Comment 2

9 years ago
> =?utf-8?B?W9Ca0J/QoyAwMDAwMDAxXTog0JrQsNGB0YHQsCDQvdC1INC/0LXRh9Cw0YLQ?==?utf-8?B?sNC10YIg0YHQvNCw0LnQu9C40LrQuA==?= 

This line is no valid UTF-8 encoded word, because there's no whitespace in the midst of "?==?". Could you please attach the source of such a mail, preferably as an .eml file?
(Reporter)

Comment 3

9 years ago
Created attachment 403243 [details]
email example

Thanks for the clue. You're right, the space between == is missing.
Its possible that phpMailer of Mantis could compose wrong message.

Comment 4

9 years ago
(In reply to comment #3)
> Created an attachment (id=403243) [details]
> email example

Thanks for the example. Its source shows that the ?==? in comment #0 is not the problem, because it doesn't exist in the message source, it's just a cut and paste error.

> Its possible that phpMailer of Mantis could compose wrong message.

Yes, definitely.

According to RfC 2047:

>    The 'encoded-text' in an 'encoded-word' must be self-contained;
>    'encoded-text' MUST NOT be continued from one 'encoded-word' to
>    another.

But this is the case in your example, the final Q is only a fraction of an UTF-8 character.

IOW: Not a Mozilla bug as such.
Component: MailNews: Message Display → MIME
Product: SeaMonkey → MailNews Core
QA Contact: message-display → mime
Version: unspecified → Trunk
Same problem as Bug 493544.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 493544
You need to log in before you can comment on or make changes to this bug.