No stack trace when running alive tests on debug builds

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
5 years ago

People

(Reporter: catlee, Assigned: ted)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Initial report here: https://bugzilla.mozilla.org/show_bug.cgi?id=518634#c1

We're not setting MINIDUMP_STACKWALK when running the alive tests on debug builds, so we don't get stack traces if we crash.
Nick's log there is the same as comment 0, presumably he meant to link to something else.
Assignee: nobody → ted.mielczarek
Unsure if this has the same root cause as bug 519194, we should look and see.
Nick, if you could find an actual occurrence of this problem, that'd help.
Try the output from "python leaktest.py -- -CreateProfile default" at the end of this http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1253846953.1253849680.21554.gz&fulltext=1

It may just be we handle the leak incorrectly, but it also seems very weird that we're hitting all those URLs when creating a profile. http://sub2.test1.example.org/ and friends, and the IDN stuff, look bogus.
The list of URLs is just from the proxy PAC stuff automation.py does:
http://mxr.mozilla.org/mozilla-central/source/build/automation.py.in#292
using the list here:
http://mxr.mozilla.org/mozilla-central/source/build/pgo/server-locations.txt

since leaktest.py uses the initializeProfile call from there:
http://mxr.mozilla.org/mozilla-central/source/build/leaktest.py.in#74

Back to the point, it looks like MINIDUMP_STACKWALK wasn't set there. When I fixed the other bug about stacks without symbols, I left in some debug prints, so if we hit this in the future it should be more readily obvious why there's no stack printed:
http://hg.mozilla.org/mozilla-central/rev/0f0239688a76
Of course, looking at leaktest.py, it looks like we'll have other problems, since it doesn't currently take any arguments at all, so you can't pass in --symbols-path.
This appears fixed in our buildbotcustom code now: 

http://hg.mozilla.org/build/buildbotcustom/file/996d58ea54a5/process/factory.py#l600

Fixing the accessory issue of not setting --symbols-path in bug 542952.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.