Closed Bug 519215 Opened 10 years ago Closed 10 years ago

[faceted search] Can't get "not involving" filter criteria back into the search by clicking on them

Categories

(Thunderbird :: Search, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: bugzilla2007, Assigned: rain1)

References

Details

(Whiteboard: [no l10n impact] [landed])

Attachments

(1 file)

My search returns 3 involved people. After excluding 2 of those as "not involved" (click on exclude (/)icon on right side of facet), I have no intuitive way of getting them back into the search. I'd expect that clicking on that spot of the icon of excluded facets again would undo the exclude action.

AR:
Only way of getting excluded facets back in is to click on the remaining *included* icon, which doesn't make sense. It also doesn't tell me anything about that action, due to lack of tooltips.

ER:
I clicked on exclude icon to get rid of facet, so probably clicking on the same spot of the icon again should bring it back into the search. Otherwise, just clicking on a striked-through facet (anyhwere from left to right) should re-include that facet. On hover, remove strike-through to indicate what will happen. Plus add tooltips.
In some cases, what happens is that when you click on the icon spot on the right of an excluded facet, it will be re-included into the search as expected (you can tell by extra results showing up), but the facet itself remains striked-through and in the "not involving" section.
That was for Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090928 Shredder/3.0pre
Ok, I sort of see this. Possibly slightly clearer STR:

1) Do a global search
2) On the people filter, click on the no-entry multiple times so that they get specified as not involving, until the last entry.
3) Do the same with the last entry.

UI gets messed up.

This happens if you expand all or not. Also happens with some people specified as involving and some as not involving.

From what I can generally work out, is that the people filter isn't happy if you specify all (or maybe all but one) people shown on the display to be under not involving or involving (hence leaving no "unspecified") people.

This error is quite frequent as well:

Error: Tried to relax a constraint that was not in force.
Source File: chrome://messenger/content/glodaFacetView.js
Line: 263
Flags: blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0rc1
(In reply to comment #1)
> In some cases, what happens is that when you click on the icon spot on the
> right of an excluded facet, it will be re-included into the search as expected
> (you can tell by extra results showing up), but the facet itself remains
> striked-through and in the "not involving" section.

--> Follow-up in related Bug 519249 -  [faceted search] Clicking on "not involving" facet removes the restraint, but facet still striked-through and in "not involving" section

This bug here might be a dupe of bug 519249, but I'm not sure.
Whiteboard: [no l10n impact]
Thomas when this bug get fixed can you double check that bug 519249 is gone too ? and if so mark the duplication?
Blocks: 519249
I will.
sid0: up for taking a run at this one after your finals?
Assignee: nobody → sid.bugzilla
Attached patch patchSplinter Review
Turns out it was a jQuery bug. Of course, poking the nodes directly has the side effect that the labels are no longer animated. Bryan: is that fine?
Attachment #406890 - Flags: ui-review?(clarkbw)
Attachment #406890 - Flags: review?(bugmail)
Whiteboard: [no l10n impact] → [no l10n impact] [has patch; needs ui-r clarkbw, r asuth]
Duplicate of this bug: 520388
Comment on attachment 406890 [details] [diff] [review]
patch

davida sorta volunteered to review this.  davida, please set this back to me if you don't get to this or don't expect to get to this before your time evaporates entirely.
Attachment #406890 - Flags: review?(bugmail) → review?(david.ascher)
Status: NEW → ASSIGNED
Whiteboard: [no l10n impact] [has patch; needs ui-r clarkbw, r asuth] → [no l10n impact] [has patch; needs ui-r clarkbw, r davida]
Attachment #406890 - Flags: review?(david.ascher) → review+
Comment on attachment 406890 [details] [diff] [review]
patch

I just looked at the patch and realized it was very short.

Let's provisionally land this but keep the bug open until clarkbw weighs in about our love of animation.
http://hg.mozilla.org/comm-central/rev/c24407db0ae1
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact] [has patch; needs ui-r clarkbw, r davida] → [no l10n impact] [landed] [needs ui-r clarkbw]
OS: Windows XP → All
Hardware: x86 → All
oops, didn't notice that I needed to keep the bug open.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 406890 [details] [diff] [review]
patch

:'(
Attachment #406890 - Flags: ui-review?(clarkbw) → ui-review+
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact] [landed] [needs ui-r clarkbw] → [no l10n impact] [landed]
You need to log in before you can comment on or make changes to this bug.