Only unique plugins should be processed; QuickTime has 7 instances

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Plugins
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: ozten, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
When creating the "browserPlugins" from the navigator.plugins object, we should filter out duplicate objects based on plugin.name.

Expected: One QuickTime plugin

Actual: We run through detection logic 7 times for QuickTime.

This does not affect the Mac OS X platform.
(Reporter)

Comment 1

8 years ago
Committing a fix to trunk, with several other changes to the code as well. r52481. 

Stage is taking up to 30 minutes to sync...
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Created attachment 403734 [details]
Post-fix screenshot
Thx, Austin; verified fixed on https://www-trunk.stage.mozilla.com/en-US/plugincheck/.
Status: RESOLVED → VERIFIED
OS: Windows Vista → All
Hardware: x86 → All
Interestingly, my QuickTime install had one .dll that was reporting a lower version number (7.6.2), with all the other ones reporting the latest version (7.6.4). The plugincheck page gave me two entries for QuickTime, one showing 7.6.2 and one showing 7.6.4, but suggested that they were both out of date.
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
Ted can you go to http://pfs2.ozten.com/pfs2_json.html and then attach the output (select all, paste) and I will look into it. Also add what os and Fx version. Thanks.
(Reporter)

Comment 6

8 years ago
(In reply to comment #4)
Ted provided
http://pastebin.mozilla.org/676606 and about:plugins output -
http://pastebin.mozilla.org/676608

The way we filter out duplicates from the navigator.plugins object is based soley on plugin name. We end up with 2 QuickTime because Apple puts the version number in the name.

The root cause of this is Apple's plugin install has a bug (AFAIK) and I don't think we should put in a special fix for this weird case, unless it's more widely reported.

*We should* push Apple to fix their iTunes / QuickTime update process to remove older plugins.
Yeah. It would be nice if it handled the "up to date" status of each of those versions correctly, though. In Firefox 3.5, it tells me they're both up-to-date, whereas on trunk it tells me they're both out-of-date.
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.