sorting on actual_time/deadline/percentage_complete cause errors

RESOLVED DUPLICATE of bug 510944

Status

()

defect
RESOLVED DUPLICATE of bug 510944
10 years ago
10 years ago

People

(Reporter: docwhat, Unassigned)

Tracking

Details

Reporter

Description

10 years ago
What Happens:
  If you sort on deadline, actual_time (now work_time) or percentage_complete then you get an error like this:
  The custom sort order specified in your form submission contains an invalid column name  <<SQL from Bugzilla::Search::COLUMNS() from %special_sql>>

What I expect:
  This should work.  This worked in 3.2.xx

Notes:
 It looks like the special column sql in COLUMNS() isn't passing the order check in buglist.cgi (line 859-ish).

Comment 1

10 years ago
I cannot reproduce neither with Bugzilla 3.5 nor with 3.4.2+, so this is not a regression. We fixed it in Bugzilla 3.4.2, see bug 510944.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 510944
Reporter

Comment 2

10 years ago
Thanks.

bug 510944 showed me where the problem was: I had a custom list/table.html.tmpl that isn't compatible with some parts of 3.4. :-/
You need to log in before you can comment on or make changes to this bug.