3.5.3 incorrectly works with dynamic '<img>'

NEW
Unassigned

Status

()

Core
Layout: Images
8 years ago
7 years ago

People

(Reporter: Dmitry E. Oboukhov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.1.2) Gecko/20090820 Iceweasel/3.5.3 (Debian-3.5.3-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.1.2) Gecko/20090820 Iceweasel/3.5.3 (Debian-3.5.3-1)

In attache You can found test html-file.

If we create image which points to absent image (we want to see at
"alt" text) from general html-tag, we can see Alt-text for each image.
But If these images is created by DOM, them ALT text will be showed
incorrectly.

This bug can be fully reproduced if test file will be placed on http.

Use Shift-Reload and Reload browser's button for reproduce bug: After
Shift-Reload browser showes correctly page, after 'Reload' browser
showes broken page.

If we open test-file from locally filesystem, browser will always show
broken page.



Reproducible: Always

Steps to Reproduce:
I tried firefox/windows, iceweasel/Debian, firefox/ubuntu. All of them have the bug.
I can reproduce the problem with different rendering for Shift-Reload / Reload
over HTTP in Firefox 3.5.3 on Linux.
It works for me in a trunk (3.7a1pre) build though:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/

The error is always present when loading file://
In both builds, hmm.
Status: UNCONFIRMED → NEW
Component: General → Layout: Images
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → layout.images
(Reporter)

Comment 3

7 years ago
> The error is always present when loading file://

This problem is reproduced in 3.6.10, too
You need to log in before you can comment on or make changes to this bug.