Closed Bug 519284 Opened 11 years ago Closed 10 years ago

Mail Toolbar visibility not remembered between launches. Always displayed on startup

Categories

(Thunderbird :: Toolbars and Tabs, defect, trivial)

x86
Windows XP
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jjantolinez, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Lightning/1.0pre Thunderbird/3.0b4

TB 3.0 beta 4 always displays Mail Toolbar even if it was turned invisible before exiting.

Reproducible: Always

Steps to Reproduce:
1. Turn Mail Toolbar invisible.
2. Exit Thunderbird.
3. Launch TB again. Mail Toolbar will be visible.
Actual Results:  
Mail Toolbar will be visible, so TB does not remember its visibility status.

Expected Results:  
Remember Mail Toolbar visibility status between launches
WFM here on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090928 Lightning/1.0pre Shredder/3.0pre ID:20090928031704

Reporter could try in safe-mode and post a feedback here?
Component: Mail Window Front End → Toolbars and Tabs
QA Contact: front-end → toolbars-tabs
Version: unspecified → 3.0
Hey guys!

It is fiexd on latest nightly release "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090927 Shredder/3.0pre".

Good job!
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
-> WFM. Fixed is used for bugs with known patches.
https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution
Resolution: FIXED → WORKSFORME
Still happening for me on 2 different instalsl with latest build from 20091021 (RC1 3rd candidate), both in normal and safe-mode, on 2 different PCs (XP). It goes even further

Steps to Reproduce:
1. Turn Mail Toolbar invisible.
2. Exit Thunderbird.
3. Launch TB again. Mail Toolbar will be visible [WRONG]
4. Right click on the toolbar and UNCHECK "Mail Toolbar"
5. The toolbar DOES NOT disappear [WRONG AGAIN]
6. Right click a second time on the toolbar and UNCHECK "Mail Toolbar"
7. Then the toolbar disappears

Possible interpretation: the toggle status is remembered correctly, but the initial display/hiding of the toolbar does not take the saved status into account.
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091121 Lightning/1.0pre Thunderbird/3.0 ID:20091121183158

klint could try to remove file localstore.rdf in your profile folder (close TB first)?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
I removed the localstore.rdf but it did not change anything :(

Here are some more info on my issue:

- it happens for a profile migrated from TB2

- it does not happen on a fresh empty profile in TB3

- also, when it happens, beyond the fact that the toolbar is diplayed on startup when it should not, the toggling system does not work the first time as explained in my steps to reproduce, but subsequent toggling of the bar does work fine.
Blocks: qa-tb3.0rc1
Whiteboard: [223 Migration]
Hello again
Actually WFM again, as it was related to an extension, apparently: the Toolbar Buttons 0.6.0.8 one. I just uninstalled and installed it again, and then problem was gone.
Thanks klint.
You can write the author of extension to report the error?

In the meantime, I close the bug as WFM.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago10 years ago
Resolution: --- → WORKSFORME
Whiteboard: [223 Migration]
You need to log in before you can comment on or make changes to this bug.