Detection of duplicate argument names with destructuring formals inconsistent

RESOLVED DUPLICATE of bug 499524

Status

()

RESOLVED DUPLICATE of bug 499524
9 years ago
9 years ago

People

(Reporter: jimb, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Hardly earth-shaking, but not classy either (can we have a new priority for that?):

js> function f(x,[x]){}
typein:1: SyntaxError: duplicate argument is mixed with destructuring pattern:
typein:1: function f(x,[x]){}
typein:1: ...............^
js> function f([x],x){} 
js>
(Reporter)

Comment 1

9 years ago
Fixed by fix for bug 499524.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499524
You need to log in before you can comment on or make changes to this bug.