Status

()

--
minor
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: jonathon, Unassigned)

Tracking

3.5 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-05-05])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

I close Firefox. Later, when i open firefox, random tabs i closed from the last session will open. (Only happens when all tabs are closed, yet firefox is still up [feature])

Reproducible: Always

Steps to Reproduce:
1.Close all tabs, but leave firefox open.
2.Close firefox and start new session
3.
Actual Results:  
Last closed tab appears.

2nd experiment: "restore session" tab

Expected Results:  
Firefox with no tabs (white screen)

Updated

9 years ago
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore
In Tools -> Options -> General -> Startup, what is the selected option in the selectbox of "When Firefox starts" and what is the Home Page?
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

9 years ago
It says "show my windows and tabs from last time". I pretty much only used the home pages as a quick bookmark.   (Jimmyr.com | reddit.com | facebook.com)
I'm a little confused about what you're doing. It sounds like you're leaving a window open with just a blank tab, but that's not completely clear. And what is this 2nd experiment?
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> I'm a little confused about what you're doing. It sounds like you're leaving a
> window open with just a blank tab, but that's not completely clear. And what is
> this 2nd experiment?

Yeah that's right.

The second time, when the first tab opens back up, i close it and shut down firefox. When i start it up again. I get the restore session screen, even though it was an empty firefox with no tabs running when i closed it.
(In reply to comment #4)
> Yeah that's right.

Ok, So this is very similar to (dupe of?) bug 495123.
 
> The second time, when the first tab opens back up, i close it and shut down
> firefox. When i start it up again. I get the restore session screen, even
> though it was an empty firefox with no tabs running when i closed it.

Getting the restore session screen would indicate Firefox is crashing or you're killing the process.

Comment 6

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a4) Gecko/20100407 MozillaDeveloperPreview/3.7a4
It works for me. Please update if you are able to still reproduce with the latest nightly build  ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/
Whiteboard: [closeme 2010-05-05]
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100503 Minefield/3.7a5pre

Resolving WORKSFORME.  I cannot reproduce the behaviour using the latest version of Firefox.  Reporter, please retest this with the link in comment 6.  If you can still reproduce this, please reopen this bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.