Tortuous to remove a contact from the new header view

RESOLVED DUPLICATE of bug 456840

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 456840
9 years ago
8 years ago

People

(Reporter: dreadnaut, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.14) Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4pre) Gecko/20090928 Lightning/1.0pre Shredder/3.0pre

With "contact stars", it has become very easy to add a new contact: only one click is necessary. There is however no way to delete a contact (maybe added by mistake) without opening the Address Book and searching for the contact there, neither is an "Undo add" option available.

Reproducible: Always

Steps to Reproduce:
1. Select an email
2. Add a new contact clicking on the star next to the contact name
Actual Results:  
There is no other way to remove the star / delete the contact than opening the Address Book.

Expected Results:  
It should be possible to remove the contact with a "light" interface, without resorting to the full Address Book.

The contact star is a parallel of the bookmark star in Firefox, and it work very well to add a new contact without too much hassle. However, it requires no confirmation, and it might be pressed by mistake.

In Firefox, it is possible to press the star again: this brings up a minimal editor where a "Remove bookmark" button is available. In Thunderbird, this is much more difficult:

* no such button is present in the simple editor;
* no delete button is present in the full editor (Edit details...);
* the context-menu for the contact name does not have a delete option;
* there is no "Undo add contact" action available

The only way to delete a contact is to open the full Address Book, select the correct address book, find the contact and then delete it, which is way too complex.

Possible, alternative, solutions that come to my mind:

* add a remove contact button to the simple editor (with confirmation if more data has been added since the contact creation)
* add a remove contact entry in the context menu (with confirmation)
* add a "Show in address book" entry in the context menu
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0
Whiteboard: dupeme
(Reporter)

Comment 1

9 years ago
This might be a duplicate of bug 456840, although the title in that bug is misleading, and it belongs to a different component (Message Compose Window).

Should I add my comment there then, or the opposite?
yes, please dupe this against that bug and add comments in there.  I updated the component so it's correct now.  Thanks!
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456840
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.